Supra Forums banner
1 - 8 of 8 Posts

·
Guest
Joined
·
231 Posts
Discussion Starter · #1 ·
Okay, I have just finished replacing my stock CT-26, because my old one was burning oil like a motherf***er. Just now I started up the car, seems to be running fine, drive it around the block etc. etc. Once everything seemed to be alright I found a nice open strech of road and stamped on the acclerator. I got a HUGE kick in the pants, as it boosted to 12+ PSI (usually I'll do 8.5-9), followed by fuel cut and a quick flash of the check engine light.

Obviously, something wasn't hooked up correctly when I was installing it or it wouldn't be boosting so intensely. There was one noticeable difference between my new and old turbocharger, that may be to blame.

Below is a picture of the old turbo, the two bits circled were connected by a black hose, on the new turbo, the one on the right didn't exsist, so my dad and I capped off the one on the left and thought nothing of it. Should there be a hose on there? If so, where should it lead?



Thanks for any and all help!
 

·
No One Ever Listens To Me
Joined
·
5,467 Posts
lol yes you need to take the old port out and put it on the new turbo...that line transfers pressure from the compressor housing to the wastegate actuator and tells the wg when to open. if its not there you are basically going to boost the shit out of the turbo because the wg will not know when to open.

transfer the port from your old turbo and connect a hose. and youll be fine.
 

·
ƒ=1/2π(√k/m)
Joined
·
10,130 Posts
LOL


Get the old nipple off the old turbo, and put it on.

The pressure opens the WG so you don't over boost, like you did.

(EDIT)
Damn you Jayson! :lol:
 

·
Ask First Search Later
Joined
·
519 Posts
umm yeah,they connect to each other,so i imagine youll need both.you got a pic of the new one?and its for the wastgate actuator,which actuates the wastegate!lol.which means you werent bleeding off excess boost which caused that.and im pretty sure w/o fuel and air mods,our cars wont handle it.correct me if im wrong about anything!

(edit)
i know,i can never help out anybody on here because someone always beats me while im typing.and yes im whining
 

·
No One Ever Listens To Me
Joined
·
5,467 Posts
MK3Brent said:
(EDIT)
Damn you Jayson! :lol:
im good like that ;) i find it funny the first thing out of both of us wasnt help it was "lol" heh....
 

·
Guest
Joined
·
231 Posts
Discussion Starter · #6 ·
Haha thanks guys, yeah I'm kind of a n00b but hey that's why I'm here. Thanks for the help! I'll post when it's all fixed up.
 

·
No One Ever Listens To Me
Joined
·
5,467 Posts
emiliorescigno said:
Haha thanks guys, yeah I'm kind of a n00b but hey that's why I'm here. Thanks for the help! I'll post when it's all fixed up.

no problem man...we all started somewhere....that should fix your problem. and this is another example of why i HATE FCDs.....if you didnt have fuel cut you would have blown your shit up.
 

·
Guest
Joined
·
231 Posts
Discussion Starter · #8 ·
Alrighty, I found what I needed, threw it all together, and now it's boosting happily! Thanks for the advice guys!
 
1 - 8 of 8 Posts
Top