Supra Forums banner

1 - 4 of 4 Posts

·
100% Stock
Joined
·
124 Posts
Discussion Starter #1
Hello, I just put my 94' 6-speed(100% factory stock,85k) on the road thursday. The car was running like a champ thursday, and also friday. Tonight i noticed my car didn't seem to be running as strong. It seemed almost like the car was missing at high rpm's(5-7k). When the 2nd turbo seemed to be coming on, the car didn't have the pull it once had. I thought it was strange. I did a few test pulls rolling around 2k in 3rd and punching it and running up to 6800. From 2k-4500, everything seemed to be normal.

These are the following things i've gathered. From 4500 or so on up to redline, the car at times almost seems to hesitate? When the boost should(or is?) rolling on from the 2nd turbo, the car has hesitation spots almost like the car is missing. I don't know why plugs would be fine one day and then bad the next. I also noticed that thursday/friday...when i would go through 1st and shift to 2nd, i could frequently spin the tires all the way through 2nd. Now, when i shift to 2nd, the car almost has a slight bogging when i hit 2nd, and will not spin the tires anymore. It seems like a 20-30rwhp loss in seat of the pants feel. I'm not sure if maybe i have developed a leak somewhere or what. If anyone has ideas/suggestions...it would be VERY helpful. Also, can anyone tell me a good way to perform a test on the boost hosing to make sure it is holding boost? Again, any and all info is much appreciated.
Josh Mallonee(94' 6-speed)
 

·
Registered
Joined
·
22 Posts
this might help

try the ttc mod to narrow down the problem...my car had the exact same problem (loss of power and hesitation around 4K rpm) and it all went away with the ttc mod. if it works for you, then the problem is narrowed down to either a vsv or vacuum hose. by the way, i never figured out which vsv or vacuum hose on mine...and the car is still in ttc mod. let me know what happens, especially if you figure out the specific problem. lates.
 
K

·
Guest
Joined
·
0 Posts
get a boost gauge and make sure you dont have a boost leak before doing ttc stuff.... Kevin..
 
1 - 4 of 4 Posts
Top