Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
No Flames please. this is my first post. I am sure this question has been answered, but I have searched the forums to no avail. My 89 targa top leaks like crazy into the interior at the front where it seals with the post. Someone told me there is a tube that gets clogged, but it there is I do not see it. The rubber appears to be in good shape. any ideas? Also the car is actually in the shop with a blown motor. it's in great shape outwardly. it is going to take $5k to fix. is it worth it? is the car of any value without the motor running? I have had the car since 1990. Thanks
 

·
Blood for Blood
Joined
·
8,323 Posts
hmm I dont know about the MKIII

I dont know about this rube... maybe its not sitting level or you need to condition the rubber...
 

·
mahkittahluvsme
Joined
·
544 Posts
my 87 used to leak a bit right where you're talking about. Even after I replaced all the rubber. It wasn't terrible though and I got used to it because otherwise it was a great car. I think it was just a design flaw with no easy fix. BTW it's targa not targo.

As for 5K on a rebuild, that's crazy. You won't get that money back if you do it. I'm not saying it's a bad car because I loved mine. But there won't be a market for it unless it's pristine.
 

·
Registered
Joined
·
327 Posts
i had thought i heard or seen some where that you could just like tighten it down more? maybe? no maybe not idk im crazy lol, but yeah mine leaks very slightly there to, but its in the shop at the moment getting a new thermostat so we'll see what i do when i get it back
 
1 - 7 of 7 Posts
Top