Supra Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
527 Posts
Discussion Starter · #1 ·
m pretty sure i know the answer to my own question but id like a little reasurrence before i go on a scavenger in my engine bay. Last night i installed 550cc injectors in my car. Car runs great under normal driving. However, at a stop sign/light when i start to move again the car goes above 20 a/f ratio on the wideband and the car bogs for about 200 rpm then quickly returns to a 14.5 a/f ratio for normal cruising. Also when im cruising and try to give it more gas, it does the same thing. When i go to wot.....it does it but i will get a 11.5 a/f ratio when boosting. Boost was at 13 psi....it made it all the way there.


So im assuming this is a boost leak due to unmetered air getting in when you give it more throttle but i just wanted to be sure. All Ic pipes are tight but i will double check. It may be the 3000 pipe/ throttle body coupler.

Maft is set for 550cc injectors. Idle set at -15% which makes idle around 14.5-15 a/f ratio.

Any input would be great


*EDIT***** There is a small crack in the rubber hose in the pCV and in the throttle body coupler.
Im assuming this is now my problem. Do I have to go to toyota for these parts or can i just get a vacuum hose and then a 4ply coupler for the tb?

__________________
 

·
Registered
Joined
·
527 Posts
Discussion Starter · #3 ·
Trent said:
A boost leak would cause you to be too rich, not too lean. You are thinking opposite.

How did you wire in the clips for the injectors? Please tell me you used solder and didn't just tape them or crimp them together.
they are soldered together and i made sure to keep the wires the same even though they are non polarized
 

·
Registered
Joined
·
2,311 Posts
Hey man if your in dekalb this weekend i could come up and check it out with you. But i do agree with trent that a boost leak will cause the car to run rich.
 

·
Registered
Joined
·
527 Posts
Discussion Starter · #5 ·
supra8795 said:
Hey man if your in dekalb this weekend i could come up and check it out with you. But i do agree with trent that a boost leak will cause the car to run rich.
no i wont be there this weekend.....at home for summer plus going to soldiers field for formula drift!
 

·
Registered
Joined
·
527 Posts
Discussion Starter · #6 ·
also i forgot to add that the rpm drops then revs up when i hit the throttle. It drops by like 100 rpm
 

·
Registered
Joined
·
1,317 Posts
CHeck your intake hose for cracks, leaks, or holes. That will make you run lean.
 

·
Registered
Joined
·
527 Posts
Discussion Starter · #8 ·
anyone else? someone else posted on another site that the plenum (sp?) is filling up with fuel during that hesitation. Could that be the problem and the lean spot? Is there a way to correct that?
 
1 - 8 of 8 Posts
Top