Supra Forums banner

1 - 9 of 9 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I'm BPU, and i've been noticing my car has a leaning out problem... I bridged pass the fuel computers relay mod which switches between different voltages to see if maybe that went bad, but the car still leans out... I'm thinking it's the fuel pump or the injectors now.. But the injectors have maybe 30k on them?
Anyone have any ideas?
thanks,
dan
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #2
I am running really lean too for some unknown reason...760C doing only 130mph pull on 18psi BPU. I have replaced Fuel filter, fuel pump, fuel pressure regulator, coolant, problem still not solved...
I am gonna go have my HKS AFR tuned next week and see what AF ratio I am running, maybe thats gonna help me determine my problem.
BTw, my fuel injectors has over 130,000miles on them, that could be it, though I doubt it cuz I had them out 20,000miles ago replacing its O-ring and they looked in good condition still.

it could all be the 91 octan bull shit gas we are using...dont know.

Jonas
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #3
oh, I think you need to move this post to TECH section before you get bitched at...

Jonas
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Jonas,
Have you had any problems with your o2 sensors... I have, and read in the manual, that it can cause the car to either lean out or richen up..... I'm going to investigate this one a bit more.
Dan
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #6
mkiv94tt said:
Jonas,
Have you had any problems with your o2 sensors... I have, and read in the manual, that it can cause the car to either lean out or richen up..... I'm going to investigate this one a bit more.
Dan
which O2 sensor? I thought it would only effeect the car at idle, plus, mine O2 sensor only has 20,000miles on them.

My EGT probe is at top of DP, so its way too hot, melting hot.
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #8
I am running NGK6097 already. I dont think spark plug will lower EGt, we went thru this debate on TECH form already, it will only lower temp on the plug itself preventing pre-ignition.

yeh 760 is quite high...I know, suppose to be around 690-700 max. thats why I'm taking my car to dyno tune my A/F ratio.
 
1 - 9 of 9 Posts
Top