Supra Forums banner
1 - 7 of 7 Posts

·
Car is being held ransom.
Joined
·
705 Posts
Discussion Starter · #1 ·
Hello everyone,

I just got my car back after a long ordeal, and unfortunately the nightmare isn't over. My turbine on my turbo is chewed up, my clutch isnt working, there is a vacuum hose I cant find that is unplugged, I tried getting my cam gear cover off, now its tapping the cam gears when I turn on the car, something is draining the battery. Everything is going wrong. Is there anyone in the GTA area able to help me determine whats wrong with my clutch, and basically, an engine checkup. I dont know what something like this would cost me, but please PM me details and I would be glad to answer any questions. I am free all of this weekend to do these things. Let me know.

Thank you.
 

·
Premium Member
Joined
·
4,409 Posts
well they seem like pretty basic issues.

Chewed up turbo needs replacing, if its not scraping now, it will soon as it is severly unbalanced, usually happens with old accordian hoses, rubber falls in. Vacuum leak should be easy to find, just try and find the sucking sound. You sure somethings draining the battery or is it just dead?

Whats wrong with your clutch?

Ide take a look if you were out in the east end, but richmond hill is too far for me.
 

·
Car is being held ransom.
Joined
·
705 Posts
Discussion Starter · #3 ·
I have no idea whats wrong with the clutch. The pedal is to the floor and the clutch fluid is empty. I will try to bleed the line tomorrow to see if that does anything.

I think the amp or deck in my car is draining the battery. The battery was replaced less than a year ago.
 

·
Registered
Joined
·
71 Posts
SuprAng said:
well they seem like pretty basic issues.

Chewed up turbo needs replacing, if its not scraping now, it will soon as it is severly unbalanced, usually happens with old accordian hoses, rubber falls in. Vacuum leak should be easy to find, just try and find the sucking sound. You sure somethings draining the battery or is it just dead?

Whats wrong with your clutch?

Ide take a look if you were out in the east end, but richmond hill is too far for me.

AHHhhhhh crap. I got an accordian hose thats starting to crack!! :ugh2:
 

·
Big HP = Big Downtime
Joined
·
2,995 Posts
cracked accordian or the aging stock airbox. If its not completely sealed between the filter and the plastic then you'll be sucking in debris. My impeller is chipped to hell because of that but the turbo is ok. Maybe he tried to start it and left something near the intake?

Did this guy sabotage this stuff because of the problems you had with him?

With the clutch just fill it with fluid and start bleeding. It might just come back.

As for the vacuume hose that will take a bit of looking. Under the accordian, by the clutch resivouir below the intake mani are all ones that are that obvious good places to start. If you have a shop manual it outlines them.
 

·
Registered
Joined
·
3,123 Posts
Kyle87T said:
I have no idea whats wrong with the clutch. The pedal is to the floor and the clutch fluid is empty. I will try to bleed the line tomorrow to see if that does anything.

Well did the fluid leak out or what?

Replace the fluid and bleed the system. If it dissapears again check for leaks in the slave cylinder under the car, if the rubber boot inside tears it leaks fluid and it goes into the bellhousing. Check the master cylinder as well.
 
1 - 7 of 7 Posts
Top