Supra Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
352 Posts
Discussion Starter · #1 ·
well guys heres pix of my new intercooler i had it for a while but havent got my car runnin yet havin problem wit adjustin valves hehe...but i think tomoro it shall start ! oh and yes i know there is a dent... but there is not leak so...no problem..


 

·
Registered
Joined
·
352 Posts
Discussion Starter · #7 ·
im kinda embarassed of the pipes, doing a 180 degree bend is very hard and clearin it in front of the radiatior too even more diff..... ill try to get pix soon the weldin is not wat i wanted to end up wit very ugly...

heres a pic of wat my motor looks like now..
 

·
Premium Member
Joined
·
6,130 Posts
What kind of IC is that man? and the deminsions? aight peace
 

·
Registered
Joined
·
1,720 Posts
Looks nice. I want to see pics of your pipes as I am doing the same thing. Also, what kind of turbo is that? The exhaust turbine is huge!
 

·
Registered
Joined
·
352 Posts
Discussion Starter · #11 ·
it is a apexi intercooler.. it is the skyline intercooler upgrade...
got some news guys i got my car runnin today but i have a problem wit the idle. the cps sensor is pushed all the way to down to keep the idle. i know it should not be like dat wat else could it be...
 

·
Canada, Eh?
Joined
·
2,460 Posts
check your timing, could be a clogged idle speed control valve, make sure the throttle body isnt sticking (it can get alot of oil buildup from the PVC system)
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top