Supra Forums banner

1 - 6 of 6 Posts
N

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I have yet another sound coming from the driver side of my car while driving at slow speeds. It's a loud metallic clicking sound from the driver side( I think). Any ideas on what it may be? Is it time to head back to the Toyota service shop for the 2nd time in two weeks?:(

Could it be the front brakes? (The rear brake pads were replaced 2 weeks ago).

As usual, any ideas or advice would be both helpful and appreciated.

nike
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #2
My car is making the exact same sound. I have no idea what it is. Gonna be taking it into the shop on wednesday to find out what it is. I'll letcha know what they find out.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #3
My car made the same noises.Turned out it was the rear wheel bearing on the left rear.I replaced both sides when I did the brakes and no more noise.

Joe
 

·
Registered
Joined
·
13 Posts
Check your EGR hose...I have no idea why it made the noise, but my car was making a funny ticking noise under acceleration and it turned out my EGR hose under the brown canister had blown off. Clamped it on tight, no more noise...and no more boost leak either.
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #6 (Edited)
The sound didn't happen right after...maybe a week or so after..

Rifter - When you do find out what it is please let me know.:)

joe - how much did it cost to replace both sides? And do you know if it's covered under extended warranty or if it's considered wear n' tear?

Mark - Hmm...I'll take a look at the hose.

Thanx for all the responses/help guys:) It's greatly appreciated.

nike
 
1 - 6 of 6 Posts
Top