Supra Forums banner

1 - 3 of 3 Posts

·
Banned
Joined
·
291 Posts
Discussion Starter #1
my car is a 95 NA MKIV and the clutch is stock. the clutch has been squeaking for some time now, but it has gotten worse and now it is just way to loud and annoying.

as soon as i start the car and it is at idle, without the clutch pedal being pressed in at all it squeaks loudly. but as soon as i press in the clutch about 2 inches or so, the sound goes away.

the sound also continues while i am driving. you know it is bad when you can hear the noise from inside the car while driving with my BL 4" exhaust. (it is very faint, but still heard).

from the outside of the car it is very loud and sounds like something is loose, but i do not know what to check.

any help is appreciated

thanks,
Heath
 

·
Exiled Supra Owner
Joined
·
3,703 Posts
Sounds like your throw-out bearing is going bad. If your still on your original clutch with high milage or didn't change out the throw-out bearing when you got a new clutch, I would get the throw-out bearing changed. (Yes, you will have to have the transmission dropped to get to the bearing - minus as well think of replacing a new clutch if your going to go through all that work).
 

·
Banned
Joined
·
291 Posts
Discussion Starter #3
thanks for the info

well my car has about 139k on it, but the motor has roughly 60k on it and still has the original clutch. dont know why the throw-out bearing would be going bad already at this mileage. is there any way to test this before i take everything apart and find out thats not really the problem?
 
1 - 3 of 3 Posts
Top