Supra Forums banner

1 - 20 of 46 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1 (Edited)
Hi, car drives perfectly fine but when parked or coming to a stop at low idle Supra start's bogging out and sometimes even turns off.

I’ve tried different MAF sensor, different ECU, replaced the MAP sensor, new Idle control valve, new fuel pump, new spark plugs, pigtails, etc.. Any suggestions?!
 

·
Registered
Joined
·
4,448 Posts
A lot of times, an ECU reset will get the IAC on a different "step" and get the idle back to normal. But I see you replaced the IAC - was that a Toyota part? They are like $450!

On cars where the idle is not adjustable (like our's), cleaning the throttle body will bump the idle up 100 RPM. If there is carbon all around the throttle blade area, that will make the idle a little lower.

Al
 

·
Registered
Joined
·
75 Posts
Discussion Starter #3
Thank you for the quick response. Yes original Toyota Aisan Idle control valve. Also checked throttle body and it's clean no carbon build up. ?
 

·
Master Shit Fixer
Joined
·
3,472 Posts
TPS adjusted correctly? Do you have a BOV?
 
  • Like
Reactions: Shady 2jz

·
Registered
Joined
·
75 Posts
Discussion Starter #7
How do I check adjustment? I've never touched it since purchased. Yes. The vehicle came with a Blitz BOV.

Thanks a lot.
 

·
iSPOOL
Joined
·
1,349 Posts

·
iSPOOL
Joined
·
1,349 Posts
Not saying that's the problem but it makes me wonder if it's TPS. I had similar issues with my automatic.

Does it act up when cold and warm too? Stock ecu and intake manifold? What's your spark plug gapped at?
 

·
Registered
Joined
·
75 Posts
Discussion Starter #12
Yes I swapped with another ECU to discard that possibility and same problem.

Initially the problem was when stepping on the gas I would get a rev cut at 4k rpm. (even parked)
I removed the intake filter and that stopped completely but now low idle is acting up. Weirdest thing ever..
 

·
Registered
Joined
·
867 Posts
I have the same issue when the car gets up to operating temp. When coming to sudden stop signs/stop lights or even at idle it bogs down to around 500 rpms and bounces around. Issue spans across multiple ECU's. Have checked my IACV but no TPS adjustment yet
 

·
Master Shit Fixer
Joined
·
3,472 Posts

·
Registered
Joined
·
4,812 Posts
I have the same issue when the car gets up to operating temp. When coming to sudden stop signs/stop lights or even at idle it bogs down to around 500 rpms and bounces around. Issue spans across multiple ECU's. Have checked my IACV but no TPS adjustment yet
exactly whats happening to me. was hoping it was a IAC issue but havent gotten around to checking yet.
 

·
Mind if I do a J?
Joined
·
3,345 Posts
You guys having this issue, are you single turbo and stock ECU? Are you running a filter on IACV? Should be a hose from IACV to intake pipe after MAF so you’re using metered air.
 
  • Like
Reactions: Dumeinao

·
Registered
Joined
·
867 Posts
Stock twins. Issues spanning across two 3 separate OEM ECU's that were tried. My recent is a Gforce ECU

Havnt tried another IACV yet

Planning to go single very soon
 

·
Registered
Joined
·
482 Posts
Stock twins. Issues spanning across two 3 separate OEM ECU's that were tried. My recent is a Gforce ECU

Havnt tried another IACV yet

Planning to go single very soon
Check your intake air throttle bump stops. Mine wore down/vibrated at certain temps and RPM dropped so much a few times the car stalled. Easy way to check if its steady is to look at your throttle position %. Ibhad to manually adjust my screw about 2 turns to raise my idle 150 RPM. No more stalling or severe drops. It's still not 100% smooth though. Just give your throttle screw a bump with your hand while running and see what happens.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #20 (Edited)
Still no luck on my end. The BOV is an old school blitz model.

Anyone knowledgeable in South Florida area? Let me know I can bring the car to you. Thanks everyone.
 
1 - 20 of 46 Posts
Top