Supra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all. My name's Fred. I've been having an issue with the heat in my RHD 1993 MKIV - NA. I have searched and searched and tried everything that I've seen mentioned on here and other places as well and no improvement. The heat comes out lukewarm in all vents however blows just slightly warmer (not by much) out of the center vent closest to the driver. I've checked and flushed the heater core twice! Both hoses to the heater core on the firewall are warm to the touch. The first time I flushed it, a bunch of sediment came out and I was for sure that was my issue. Turned the heat on and it was still lukewarm. I then checked the thermostat by removing it and placing it in hot water until I saw it open and removed it and watched it close. That checked out fine. I flushed the coolant in the entire system and replaced it with the OEM Toyota Red Coolant just for good measure. Still have lukewarm heat. I then started removing parts of the dash and watched the blend doors move as I switched the control from AC to heat. I could only locate 2 blend doors. Both on the passenger side with one up top closest to the windshield and one below closest to the floor board. Can anyone advise if there are more and their locations? I have also checked my fuses, all fuses are good. Also, I have no coolant leaks either. I looked around inside the car, thinking I may have a heater core leak and I did not see any wet spots, coolant, leaks, etc. The car does not overheat and stays within normal operating temperature. Guys, I am at a complete loss. What could I possibly be missing? I feel like I'm overlooking something because it should not be this hard. LOL! Any help would be GREATLY appreciated. Please chime in with any thoughts. Thanks in advance!!

Again, things I have already checked:
- Coolant level
- Air in the coolant system (I completely burped the system)
- Thermostat
- Heater core for leaks
- Heater core hoses (both are warm)
- Flushed heater core
- Fuses (inside the car and in engine bay)
-Blend door operation (could only locate 2) (Anyone know if there are more??)

Thank you,
Fred
 

·
iSPOOL
Joined
·
1,316 Posts
Have you hooked up to a scanner to see if its throwing any codes? Cross checked it through the TSRM?
 

·
iSPOOL
Joined
·
1,316 Posts
249361

249362
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4 (Edited)
Thank you! I noticed it says that the water valve should be #1 for troubleshooting areas. If the heater core is able to be flushed, shouldn’t that mean that the water valve is good?

Also, can anyone chime in on approx what temperature the heat gets in their car coming from the vents?

EDIT

So I inserted clear tubing into part of the hoses going to the heater core and it looks as though coolant is just sitting in the hoses and not circulating or moving at all. Any ideas?
 
1 - 4 of 4 Posts
Top