Supra Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
So yesterday I was replacing my K&N FIPK and decided to go ahead and clean the MAF out. So I ran down to autozone and bought this can of $7.99 MAF cleaner to use. I spray MAF housing and let the excess run off and the housing dry. About an hour later I put this all back together and when I go to start the car it wasn't starting. It would begin to start and just die. Now my check engine light is on as well. Then it starts with me giving it some gas. Everytime I would rev it the engine would die as the rpms returned to idle speed. So I paid $7.99 for this "special "safe" cleaner" to fry my perfectly operating MAF. Luckily I had an extra MAF sitting in my garage that I was able to hook up.

http://www.crcindustries.com/auto/content/products_ss.aspx?ID=90

That is what I used. Has anyone else ever had problems with this stuff or similar cleaners? Any idea how this stuff jacked up my MAF? I tried calling their customer service of the company but I guess they don't work weekends.:bs:
 

· Registered
Joined
·
92 Posts
Discussion Starter · #5 ·
If it's that CRC cleaner, I remember seeing "not for turbo charged vehicles" on the back label.
No its safe for use on all gas powered vehicles with a MAF Sensor. I went back out to the garage and read the entire label again just to make sure. I'm not even sure how that spray killed the sensor. I'm just kinda wondering what this company is going to tell me when I call them on Monday. I'm sure they are going to try to connect this to operator error. I mean it is quite hard to disconnect a MAF and spray it... not. I'll update when I find out more.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top