Supra Forums banner
1 - 16 of 16 Posts

· Registered
Joined
·
1,201 Posts
-94
-6 speed
-obd1
-Works pretty good, has a stutter in between shifts which seems to be common, but I think it can be tuned out.
-All in all I like it, pretty easy install and has alot of features for a piggy back and is well priced. Id use it again.
 

· EchoDeDupra
Joined
·
7,159 Posts
-1994
-6-spd
-obd1
-works pretty good... still having a few issues, but they are all due to that fact that I tuned my car to just drive me around as I am waiting to install my fuel system upgrade
-it does everything I have expected it to do

:sadance:
 

· Registered
Joined
·
683 Posts
-94
-6 spd
-obd 1
-Only tuned it to get the car running. The hesitation after shifts is annoying.
-other than the hesitiation, I like it because its simple to tune alnd exactly what I expected. Which was to be able to tune it myself and datalog on a laptop.
 

· Boost4fun
Joined
·
1,931 Posts
Wow so many 94 M/T
Ok here we go:
-94
-M/T
I like it and it doesn´t stumble after shifts. Guys, if you are having this issue check for the enrichment table for fast throttle movement. Reduce this to 6 to 8% and it should be fine. Play a little arounf with that. Mine runs great w/o any hesitations.

I like the unit and it performs flawlessly. I used the PHR base map and tweaked it a little at WOT and that was it.

Gerd
 

· Registered
Joined
·
1,771 Posts
-94
-M/T
-obd 1
-had lean tip in then adjusted TPS and fixed it. Tuned myself and car ran fine except when outside temp would swing far then would change AFR's slightly (used AIT sensor).
-I liked it but went AEM. Not a bad piggy back though in my book.
 

· 2JZ yes shit
Joined
·
1,208 Posts
-96 NA-T (63mm)
-M/T
-obd2
-i don't have any of my stock o2s connected as the wideband took up the available bung for now, but it seems to help the MAP-ECU, because it forces the computer into open loop 24/7 which means it reads off the MAP-ECU 100% of the time. because of this, my tune has been spot on and has never slowly leaned out over time. i've never had to reset my ecu, and my a/fs have been exactly the same since the first day i tuned it and gas mileage is very good for being single.
 

· Registered
Joined
·
683 Posts
Dj_Diablo said:
-96 NA-T (63mm)
-M/T
-obd2
-i don't have any of my stock o2s connected as the wideband took up the available bung for now, but it seems to help the MAP-ECU, because it forces the computer into open loop 24/7 which means it reads off the MAP-ECU 100% of the time. because of this, my tune has been spot on and has never slowly leaned out over time. i've never had to reset my ecu, and my a/fs have been exactly the same since the first day i tuned it and gas mileage is very good for being single.

Hmmm never heard of anybody doing that, does the ecu only do that on obd 2?
 

· Banned
Joined
·
666 Posts
-93.5 Single Turbo
-Auto
-odb1 :-(
-works great, only problem A/F wideband input fluctuates sometimes but i think that is a bad connection on my part
- works as intended for MAF controller, easy to use/setup/install, wish it had more ADC inputs, i would wait for v2 or whatever the next thing they have coming out
 

· Captain Hammer
Joined
·
1,992 Posts
89 APU
Auto
Neither
Loved it, was great, gone to haltech.
 

· Registered
Joined
·
250 Posts
Dj_Diablo said:
-96 NA-T (63mm)
-M/T
-obd2
-i don't have any of my stock o2s connected as the wideband took up the available bung for now, but it seems to help the MAP-ECU, because it forces the computer into open loop 24/7 which means it reads off the MAP-ECU 100% of the time. because of this, my tune has been spot on and has never slowly leaned out over time. i've never had to reset my ecu, and my a/fs have been exactly the same since the first day i tuned it and gas mileage is very good for being single.

What is your timing like with the stock o2s disconnected? Someone else did that and said his timing wasn't as advance with the o2s disconnected. Jarret doesn't recommend it. I do like the idea if the timing isn't affected.
 

· Registered
Joined
·
2,565 Posts
Discussion Starter · #16 ·
answer my own questions, i decided to get it and hooked it up no problem....

-1993
-auto
-obd1
-works good, i just need to get a wideband to tune it right
-it works good, again just need to get the wideband
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top