Supra Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
2,087 Posts
Discussion Starter #1 (Edited)
ive been having trouble with the car, the CEL has been on and off as well as trac, i narrowed all possible problems down to the Mass air flow sensor,

the car randomly starts bogging and not accelerating, i have to get out and move the MAF connection around till it stops but it usually doesnt last long until it does it again.

Do you guys thing it could be due to the MAF sensor being dirty? Faulty?

i checked the wires and connector and it all looks fine...

has anyone had this problem before?
 

·
Registered
Joined
·
1,684 Posts
hey jordan did you recently wash the engine? Sometimes water can cause this issue as the MAF sensor is a very sensative P.O.S.
 

·
Registered
Joined
·
2,087 Posts
Discussion Starter #3
nope i have never washed the engine bay using direct water, only spray cleaners on a rag and wipe. so it couldnt be that.
 

·
tastie treats
Joined
·
2,550 Posts
I had a problem with my MAF when I went single. If I slightly boosted and came to a stop, my car would die. Do what I did. Remove the MAF =)
 

·
Registered
Joined
·
2,087 Posts
Discussion Starter #5
well my MAF cut out on me again on the way to school at 630am=[

thank god i have AAA they took the car to FSR, hopefully we can figure this out in the next day or two.

Jason i can remove the MAF on the stock ECU? Would the car run okay?
im already at low boost 10psi, wouldnt it run super rich?
 

·
Registered
Joined
·
653 Posts
well my MAF cut out on me again on the way to school at 630am=[

thank god i have AAA they took the car to FSR, hopefully we can figure this out in the next day or two.

Jason i can remove the MAF on the stock ECU? Would the car run okay?
im already at low boost 10psi, wouldnt it run super rich?
If you remove your mass air flow your car will turn off and wont run. They usualy go for cheap on the sale section for a used one.
 

·
Registered
Joined
·
1,684 Posts
^^^ Bingo.... no way car will run without it man.... Jason did you use a HKS VPC or something of that nature?
 

·
Registered
Joined
·
395 Posts
jordan buy c&r maf cleaner i think thats what its called i had the same problem and i cleaned my maf and it ran so much better and my maf sensor have 240k on it lol
 

·
tastie treats
Joined
·
2,550 Posts
If you remove your mass air flow your car will turn off and wont run. They usualy go for cheap on the sale section for a used one.
^^^ Bingo.... no way car will run without it man.... Jason did you use a HKS VPC or something of that nature?
Negative, I'm on a stock ecu with no MAF. The car runs rich however Jordan.
 

·
tastie treats
Joined
·
2,550 Posts
You either have a JDM motor, or you are driving around in limp mode which is just retarded.
What is more retarded? Constantly stalling in traffic or limp mode? I'm just not a fan of accidents being rear-ended once.
 

·
Registered
Joined
·
2,087 Posts
Discussion Starter #14
thanks for all the input guys were still trying to figure it out.
I would buy a mapecu or aem piggyback but im broker than shit right now

and i asked FSR if taking the MAF off was an option and they said yes it just runs rich, im sure fsr wouldnt let me take my car in limp mode or stalling like crazy. they must have some way to bypass it. anyways hopefully cleaning it well will do the trick,
also another possibility could be the fact that i have no heat shield on my twins... maybe that it fucking with the wires?

also FYI the car only goes into limp mode anmd acts up when its hot and been driving for a few miles.. so maybe a heat issue?? but if i let it cool down it works again for a little while...
 

·
Exiled Supra Owner
Joined
·
3,703 Posts
There might be dirt traped inside the MAF, but blowing it out can be a pain. I don't suggest compress air as it will damage it. MAF's are cheap on the for sale section.
 

·
Registered
Joined
·
3,616 Posts
What is more retarded? Constantly stalling in traffic or limp mode? I'm just not a fan of accidents being rear-ended once.
Just do it right and put a new MAF on. You can get a used one on the forums for $50. Or just convert it to a MAP setup.

You should be driving your DD around until you get it fixed.
 

·
Registered
Joined
·
2,087 Posts
Discussion Starter #17
DD is sold due to it not being smogable

and its not looking like its the MAF now
looks like cyl 5 and 6 are having ignition problems
compression is fine
im ordering new coil packs so well see how that goes
 

·
tastie treats
Joined
·
2,550 Posts
Just do it right and put a new MAF on. You can get a used one on the forums for $50. Or just convert it to a MAP setup.

You should be driving your DD around until you get it fixed.
I've tried a couple MAF's and in all situations, it wasn't working out. The car would run fine but at any point of slight boost followed by braking, the car would die on me. A map ecu would be great but being unemployed doesn't allow for much.
 

·
Kickin'G ASs 24/7
Joined
·
1,636 Posts
Hey Jordan, if you want you can come pick my coilpacks up, and try them on, i know mines are working just fine, so if you dont want to spend the money of new ones, come on by and check them out bro, i always say if its not necessary dont buy it, specially when you have supra buddy's you guys can alsways swap out parts to eliminate possibilities, i had Octavio back in the day's, and i thank him alot for that...!!:cool:
 

·
Registered
Joined
·
2,087 Posts
Discussion Starter #20
fuck lol i wish you would have told me that before i ordered new ones

*facepalm*

but thanks anyways man,

you wouldnt happen to have a upper wiring harness laying around would you?
haha
 
1 - 20 of 27 Posts
Top