Supra Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
i was in a front end accident and both airbags went off and the intercooler and radiator and condenser and harmonic ballinser and and water pump were damaged and now that car car is all back together it cranks but dose not start it will crank , and i here the fuel pump on .
and i do have a aftermarket alarm
can any one help me to figure out what wrong
with me 94 supra
 

· Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
ill check all the grounds but i never took the crank angle sensor just the crank pulley
when i put the new crank on there was a ring with a holes in it (i for got what it was called) but i think i might of put it in wrong possibly .
because i could not fined any think to go off so that i would know witch way to put it in i never took the crank out of the car just took off the crank pulley and i did not remember if the ring with holes in it when behined the plastic cover or in front with the the crank pully
but if you know the right way to do it let me kno
thanks
 

· Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
no the crank sensor is fine but the car will still not start is there and like check ball or resistor or a vacuum controlled switch or solenoid in the fule system cuz it souds like when the key is on and the fuel pump running it sounds like at the rail like there is just small or no fule in the line maybe just air a gurgling sound is coming from the rail
dose anyone kno if they can help me
 

· King of Snark
Joined
·
2,126 Posts
check the plugs.. are they clean? black? white?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top