Supra Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
948 Posts
Discussion Starter #1
new mk3 was burnin oil lika mofo and not building boost, pulled off the i/c piping and no surprise, about a quart of oil, cleaned the IC out and all the piping with gasonline put everything back togather, still didnt build boost, but ran clean for a few minutes and back to burinin oil like a mofo. piping fillled with oil again. not to familiar with cars with emissions lol. hows this work, lol cracked pistons is an option i imagine, as is rings, anything less serious that i'm blatantly overlooking?
 

·
Registered
Joined
·
212 Posts
haha well did you check your turbo mine is blown and burns oil like a mofo too!! But that sounds bad... hmm
 

·
Registered
Joined
·
212 Posts
damn beat me to it!!
 

·
Registered
Joined
·
948 Posts
Discussion Starter #5
its a fresh 60 trm ct26, theres NO shaft play at all.
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
76celicagt said:
its a fresh 60 trm ct26, theres NO shaft play at all.

sounds like your turbo is blown.
 

·
Registered
Joined
·
212 Posts
did you tighten everything right up?? When did my hg job i didn't tighten the bolts to the turbo down and oil went EVERYWHERE!!! Check that.
 

·
Registered
Joined
·
948 Posts
Discussion Starter #8
turbo blown with no shaft play?
 

·
Registered
Joined
·
948 Posts
Discussion Starter #9
and why would it not boost? turbo spins freely, ive seen ct26's that had rediculous shaft play that still boosted
 

·
Registered
Joined
·
212 Posts
BHG haha.
 

·
Registered
Joined
·
948 Posts
Discussion Starter #11
def no BHG, doesnt smoke white, doesnt overheat. no weird waterfall sounds.
 

·
Registered
Joined
·
212 Posts
Check all of the lines that go to the turbo and the oil line!! check the little gaskets on the turbo...again check ALL of the bolts if you have to take off the turbo and DOUBLE check EVERYTHING just in case!
 

·
Registered
Joined
·
948 Posts
Discussion Starter #13
oil is INSIDE, the IC piping not outside of... i dont think its something loose on the turbo
 

·
Registered
Joined
·
3,727 Posts
take the acordian hose off and if there is oil up on the wheel and stuff then its the seals. time for another rebuilt or something better
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
BLOWN TURBO! send it back and tell them the front seal is shot. mine did the same thing w/next to no shaft play.
 

·
475RWHP 449TQ and climing
Joined
·
5,911 Posts
Blown turbo or cracked piston! Why would it hate itself. Bet some thing like age or boost caused this! You guys want to boost an old engine and wonders why it dies....what a joke!
 

·
Registered
Joined
·
1,418 Posts
bad rings/blow-by will do the same thing as long as you have your pcv system hooked up properly (stock). it'll blow out through the cam covers, and get sucked back in by the turbo, then blown into the i/c where it will sit. do a compression check if you are certain it's not the turbo.
 

·
Registered
Joined
·
205 Posts
Usually, if the oil is NOT going out the exhaust, it is usually not the Turbo. You need to do a compression, and leak down test. Generally the oil in the intercooler comes from the blow by from the PVC system. You need to check each cylinder, when and if you find the cylinder low, turn the crank to TDC and put compressed air in and find out where it is going. I had a lot of carbon built up on #6 and the air came out the exhaust. After fixing that, the rings were bad and I have to pull the motor.
 

·
ODS
Joined
·
847 Posts
Who built the turbo? I had the same problem with a 60-1 I got from a specific person that builds the turbos and they rebuilt it after many unhappy conversations and threats to take them to court...

SMo'
 

·
stop pulling me over pigs
Joined
·
1,259 Posts
Why is it that every time one of us whines about something wrong with our mk3, every ellse claims BHG!?
...oh yeah, because about 95% of them are usually right.

Well, I've at least concluded mine isn't blown....YET.
 
1 - 20 of 20 Posts
Top