Supra Forums banner

1 - 5 of 5 Posts

·
"DANNY TANNER!!!"
Joined
·
1,847 Posts
Discussion Starter #1
NO BHG......i have a 4 year old regular replacement rad with flex-a-lite fans. I have a nice FMIC in the front so it does block the airflow to the rad a bit (not a problem since A TON of us have FMICs). Now on the highway i have to keep my heater blasted at full just to keep my water temps down. If i turn it off it'll just slowly keep on rising. If i turn my flex-a-lites on it makes matters worse and actually makes my car run hotter. Now in stop and go traffic if i have the flex-a-lites on they work wonderful. It'll keep my car cool.

So basically my car doesn't seem to cool itself while driving. I haven't changed coolant in a long time, possibly close to 3 years. Could that be the cause to my annoying problem?? I hate having to run my heater on full blast constantly becasue i sweat my balls off on hot hot days.

Derek
 

·
Business Baby
Joined
·
840 Posts
I'm having somewhat of the same problem, my car will overheat for no reason, it's not smoking or anything, and they coolant is the same color as it was when I poured it in......
 
K

·
Guest
Joined
·
0 Posts
kinda sounds like you have a head gasket on its way out. or maybe ur cooling fans aren't working properly. this happened to me on my old 89 4runner. ended up being a BHG.

and if ur coolant is 3 years old. i would suggest changing that. it can get kind of "muddy" in there after a while. i try to change my coolant once a year.
 

·
Moderator, l337 M0d3r4t0r
Joined
·
12,222 Posts
check to see if the neck of the rad is leaking coolant.

Replace cap as they said.

Could be a HG problem even if coolant looks good.
 
1 - 5 of 5 Posts
Top