Supra Forums banner

1 - 18 of 18 Posts

·
At My Signal Unleash Hell
Joined
·
820 Posts
Discussion Starter #1 (Edited)
Hello all,
I went to the track last Monday and had pretty good runs.
My best was a 12.40 @ 110mph at 20psi. (on street tires)
I have two videos of one run from inside the car
First video is of a 12.6 @ 115mph run
The second video is of a 12.7 @ 118mph run
I'll scan my timeslip tomorrow and I'll post it

http://www.rwsupra.com/videos/track.wmv

--Oliver
 

·
Registered
Joined
·
166 Posts
nice vids man, are you a 5spd? and what numbers is that bad boy putting down?
 

·
Registered
Joined
·
46 Posts
Is it supposed to be that bouncy when doing a burnout and a launch? The incar video really shows it. Nice car also. Is it your daily driver, how has reliability been?
 

·
Hardtopper
Joined
·
13,043 Posts
I tried looking for the thread where you put up pictures of your NA-T but no luck..

What setup are you running, turbo, fuel, clutch

:) Nice runs, car sounds damn good
 

·
Wingless Hardtop Moderator
Joined
·
3,090 Posts
Thats badass man, is your car a hardtop se? and kirk.. its an SP 60.. notice the sig =) Im assuming race gas at 20 pounds.
 

·
Toyotally Awesome
Joined
·
647 Posts
oliver said:
Hello all,
I went to the track last Monday and had pretty good runs.
My best was a 12.40 @ 110mph at 20psi. (on street tires)
I have two videos of one run from inside the car
First video is of a 12.6 @ 115mph run
The second video is of a 12.7 @ 118mph run
I'll scan my timeslip tomorrow and I'll post it

http://www.rwsupra.com/videos/track.wmv

--Oliver

You must not have been running the same specifics to net a 118 mph trap when you dynoed at 486rwhp. In no way am I calling either of the two b.s., but were the conditions of the pass/dyno run (psi, temp, race gas, pump gas...etc)
 

·
« f ï z z | ë »
Joined
·
761 Posts
do you have lsd?

one day i will be na-t............ one... day.... :D
 

·
At My Signal Unleash Hell
Joined
·
820 Posts
Discussion Starter #11
Thanks Guys!!! :)

5speed300: Not really, its not bouncy at all, its just that the camera was not mounted tight enough and was kinda losse. I used one of the cheap camera mounts hehehe.. :D
It used to be my daily driver for about one year, then I put the turbo in and I drive it on weekends only. So far I've had no problems at all and its been about 2 years since I've gone turbo.

kirk_mk3: I have an SP-60, 550cc injectors, Walboro pump, VPC, AFC, clutchmasters IV clutch

bobmarley: Its a NA Targa :D.. yeas I was running C16 race gas :p

soarer 300: well, when I dynoed 486wrhp that was at 23psi, well it spiked to 25psi but it came down to 23psi. And when I ran the 118mph I was at 20psi. Both were with C16 race gas.

--Oliver
 

·
Registered
Joined
·
441 Posts
How is that clutch?? Im in the process of purchasing a new clutch.. I think im going with the HPF clutch w/ ACT PP

My Stock clutch lasted me 2 years and about 20k miles...

Flipn
 

·
Over Medicated
Joined
·
2,700 Posts
Good times Oliver. Looks like your running almost exactly the same kind of times as I am. 12.4's @117 range.
I know what you mean about the Stage IV clutch. I've got the CM also but this is my daily driver.:D
Are you running drag radials? If not switch and you should be in the 11's.
 

·
Hardtopper
Joined
·
13,043 Posts
Watched the videa again - I'm sure you can shave off a couple of tenths off that 1/4 time with a better launch... but even still you got some damn good times
 
1 - 18 of 18 Posts
Top