Supra Forums banner
1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
I put a turbo kit on my 92 SC300 Auto. The car drives fine but won't rev over 3500-3800rpm. I've change the following from stock:

SAFCII installed
Breather hoses left open (the 2 that attatch to the intake pipe)
02 Sensor changed to a screw in type and 2 wires merged to one
Karman Sensor is before the Turbo

I haven't got any check engine lights and the car runs fine and a/f ratio is almost perfect but the car just won't rev over 3800. If anyone has any ideas, please chime in as this is quite discouraging.
 

·
King of the NA-T's
Joined
·
4,044 Posts
What does it do at ~3800 that keeps it from reving? Does the ignition cut out?
 

·
miata owner...
Joined
·
1,367 Posts
builtsohc said:
I put a turbo kit on my 92 SC300 Auto. The car drives fine but won't rev over 3500-3800rpm. I've change the following from stock:

SAFCII installed
Breather hoses left open (the 2 that attatch to the intake pipe)
02 Sensor changed to a screw in type and 2 wires merged to one
Karman Sensor is before the Turbo

I haven't got any check engine lights and the car runs fine and a/f ratio is almost perfect but the car just won't rev over 3800. If anyone has any ideas, please chime in as this is quite discouraging.

02 Sensor changed to a screw in type and 2 wires merged to one

please dont merge o2 together!

Also do you have a wideband to see how rich your running? If your running super pig rich it wont allow you to rev over a certain rpm and etc...
 

·
Registered
Joined
·
402 Posts
i thought it was ok to merge o2s but on the side note its got to be either ignition or fuel being cut off. and sorry but i dont know what engine is in a 92 sc did they have the 2jz ge's in them that year?
 
G

·
Discussion Starter · #7 ·
I have a wideband. It runs fine (~14.7:1) at part throttle but when you get on it it goes rich (~10:1) sometimes... sometimes it'll go a little lean >15:1 so I'm leaning towards the 02sensor. btw, the motor is a 2jzge. I didn't think the ecu used the 02 sensor over a certain throttle position. Most efi cars (in my experience) switch to closed loop when you go past ~50% or so throttle position and don't even reference the 02 sensor so I figured it wouldn't matter.
 
1 - 7 of 7 Posts
Top