Supra Forums banner

1 - 9 of 9 Posts

·
Track Junkie
Joined
·
1,577 Posts
Discussion Starter #1
Okay, I took my Supra to Tuned Performane again yesterday for putting boost gauge, FCD, and Profec B. I didn't get the car until tonite. When I turned on my Supra, the airbag light and Hazzard light won't go away. Since everyone at Tuned already gone home, I would like to know how to get those lights off. Is it safe to drive with those lights on? Have a long trip tomorrow, so please help.
 

·
powered by
Joined
·
998 Posts
If they unpluged an airbag or a sensor while the battery was connected it will set a code and cause the light to come on. If they didn't plug whatever back in-it could be a problem if you happen to need your airbags for any reason. As far as the hazard light-I don't know-do your turn signals work? Where about in ATL do you live, and what time are you leaving for your trip? __
 

·
Track Junkie
Joined
·
1,577 Posts
Discussion Starter #4
I live near Peachreee Industrial and I am leaving at 9 tomorrow morning. I hope I don't need the airbag while I am driving the trip.

NakSukow, why you post a mkiv main page link?
 

·
Track Junkie
Joined
·
1,577 Posts
Discussion Starter #7
Okay, I think just found out what's the warning light is about. When crusing tonite, my car is getting slower and slower, then I stopped in the shopping center beside the road and saw the temperature gauge is about to hit the roof. Damnit, the thermostat is broken. Now the car is parking in dealer's parking lot waiting for someone stealing it :eek: Now I can't go to sc to pick up my parts :( Anyways, I also found out my internal top light doesn't light up when the doors open and can't manually turned on. I guess the wiring inside is screwed too. Bad day for me...
 

·
Ex-MKIV TT OWNER
Joined
·
92 Posts
That's strange. I've been going through similar B.S. with my supra. I had a stereo installed two days ago and ever since my ABS, Trac, lights won't go off. Also, when I shut the car off and remove the key, it keeps running?? I had to pull the fuel pump fuse to shut the damn thing off. Then to top it all off, yesterday I had Pep Boys throw in a new battery for me. When they were finished with the install the hood wouldn't open. WTF...
Now I'm stuck with a car that won't shut off and now...can't get the damn hood open to pull the fuse to shut it off.
Droped it off at the local Toyota dealership before work this morning. Can't wait to see how I get rapped on price for the fix.:mad: :mad: :mad: :mad: :mad: :mad: :mad:
 

·
Track Junkie
Joined
·
1,577 Posts
Discussion Starter #9
Okay, Toyota gives me a call just now. The find out the thermostat and the water pump both are broken. The price to fix both is $560 :mad: What a rip off... Since I don't want to spend another $75 for towing service, I decided I will have it done there... However, the best thing is I can't have the car back until Tuesday because they neeed to order the parts :( I hope everything will back to normal after it's done....
 
1 - 9 of 9 Posts
Top