Supra Forums banner

1 - 10 of 10 Posts
B

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
The .002 Run was completely Stock, even the stock paper air filter.

The .003 and .004 runs were after installation of a Greddy BCC, RMM DP and a Blitz Exhaust. I'm kinda baffled as to why the power output is lower. The turbos seems to be spooling faster, but shouldn't I see at least a increase of 20-30 rwhp. Secondly how does the A/F Ratio look. The guys at AAM said that the clutch might be slipping, but it doesn't feel that way and there is only 20K on the factory clutch. Thanks Guys!!!
 
E

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Dude whats up with your AF ratio, its under 10 above 5500 rpm! Did you pull hoses or up the boost in any way?
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #3
I haven't pulled any hoses and as far as boost goes, it went up after the install of the DP and exhaust. I havn't installed a boost controller or done the bleeder T mod. Is the AF Ratio bad? What should I expect to be seeing after the mods I've done currently. I'm the second owner and the car has never been modded before.
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Looks like the ECU pulled the *hell* out of your timing on the first run (when stock), and did so even more when you increased the boost. The stock intercooler doesn't work very well without airflow, so if you were running pump gas on the dyno, that's very likely your problem. Put some higher octane fuel in to make up for the lack of airflow, and reset the ECU. You should then notice a significant gain.

-Pete
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #5
I was running 93 Octane gas at the time. There is no where that I know of near me that has race gas. Would those octane boosters you can buy at track auto really work? Or are they just a gimmick? I'm still pretty baffled as to what's up. I just went out for a quick spin but really couldn't get on it. The car feels faster. At one point I was hitting .9 bar in fourth but I wasn't at redline yet. What type of numbers should I be expecting with the mods I have now. Thanks again guys, I'm still trying to learn as much as possible about my car, so hopefully soon I'll be able to offer more feedback and less questions.

-eddie
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #6
I just took her out for another quick spin. Winding out 3rd gear at WOT around 5000 rpm there was a slight drop in power for about .5 sec. then back on the power again. Almost as if I let off the gas completely then got back on it. Is this a sign of a slipping clutch, or timing retard due to detonation.
 

·
Moderator
Joined
·
3,148 Posts
Have you tuned your BCC. It sounds like you may be hitting your fuel cut.

Later, Steve
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #8
I've tuned the BCC with a digital Voltmeter to 4.3008V. Should I turn it down a bit. The instructions on mkiv.com said nearly but not pass 4.3V, but I didn't think that .0008V would of made a difference.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #9
No one else has any thougths???? Come on guys I know somebody out there has some input/guesses....
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #10
I agree with watermnp,I believe your computer is compensating for a lack of something.Because you bought the car second hand,I would recommend changing the fuel filter if you havent already.Just a guess of course.

Joe
 
1 - 10 of 10 Posts
Top