Supra Forums banner
1 - 12 of 12 Posts

· Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi just wanted to do a into
My name is jonathan i have been reading this forum for a while now. but just became a member cuz i just got my supra out the shop (2 years if u wanted to know)
I bought a supra with a blown motor (non- turbo auto) then bought a engine from japan that was turbo with a 5speed tranny. the turbo came from jap and is from the old evo.
Also i bought an intercooler, i have 3' piping from the turbo all the way back.
Runs great. they have me with a rev limiter at 4500 untill i break in the motor/tranny
also a ems stand alone ecu

i posted a thread because my stock gauge cluster doesn't work if someone can point me into the right direction

any advice will be great
 

· (◕_◕)
Joined
·
8,453 Posts
Hi just wanted to do a into
My name is jonathan i have been reading this forum for a while now. but just became a member cuz i just got my supra out the shop (2 years if u wanted to know)
I bought a supra with a blown motor (non- turbo auto) then bought a engine from japan that was turbo with a 5speed tranny. the turbo came from jap and is from the old evo.
Also i bought an intercooler, i have 3' piping from the turbo all the way back.
Runs great. they have me with a rev limiter at 4500 untill i break in the motor/tranny
also a ems stand alone ecu

i posted a thread because my stock gauge cluster doesn't work if someone can point me into the right direction

any advice will be great
Only gauge that shouldn't work would be the tach, the rest should work. Me thinks that they didn't hook them up, in the dash.
 

· (◕_◕)
Joined
·
8,453 Posts
Is it a AEM EMS? If so they are retarded, its plug-n-play. Unless they got you the universal one, lmao.
 

· (◕_◕)
Joined
·
8,453 Posts
it EMS (engine mangenment system) my horn doesnt work, only my gas and batt gauge works
Take pics of it, if you can't describe anything.
 

· (◕_◕)
Joined
·
8,453 Posts
All I have to say is I would not have done this, I pray for you that they piggybacked it. If not I would never go to that shop again, sounds like they did a complete hackjob. Your speedometer should work regardless, its a cable.
 

· (◕_◕)
Joined
·
8,453 Posts
Goto TRSM the link is in my sig, match the wires they hooked them up to. Not hard, but very time consuming, should have gone AEM.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top