Supra Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
ok so last week my car started misfiring on the highway while just cruising, i was only about 2 miles away from home so i just thought i would be able to make it and at a red light right in front of my apartment it sounded bad like if i was running on 4 cylinders and then the engine just shuts off. so i push it to a gas station to let it cool off for an hour. i try to crank it over to only get a loud click sound. so i thought it was a faulty starter so i ordered one along with new coil packs (super spark) and NGK plugs. finally my parts come in so i pull the old coil packs and plus off but to find cylinders 2-6 were flooded with fuel except cyl 1. so then i disconnect the fuel pump and turn the engine over having fuel fly out all over the place. sucked out the rest of the gas with a wet vac and proceed to putting on the new plugs and coil packs. i then tryed to start it, it cranked and cranked and cranked but no start. i try it a second time but this time i get a loud CLICK sound AGAIN, come to find out cyl 2-6 were flooded AGAIN!! can someone please help me out...

forgot to mention im stock. stock twins, stock downpipe, & stock injectors. any input would be greatly appreciated
 

·
Registered
Joined
·
12 Posts
Discussion Starter #2
today i took apart my ECM and found one leaking capacitor :( , could this really be what is causing my engine to flood so much? i took my car to a shop to have them take a look at it and they tell me it may be my ECM. i asked them what about a faulty FPR and they said that my ECM controls the FPR... is this correct?? i thought it was vacuum controlled. well im sending my ECU to driftmotion to replace all caps tomorrow
 

·
Poopra owner
Joined
·
565 Posts
check injector grounds on intake manifold. Im currently having the same issues with mine, and after i cleaned the grounds i was able to drive the car home. I'm on standalone, so bad ecu is unlikely..
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Just got my ECM back from driftmotion and automotive fuel pressure regulator kit today. Going to hook everything up after school and hopefully she fires up!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Well it got the car to start now but there's sill a problem where it's still dumping too much fuel in cyl 3 & 5. I just bought an AEM standalone waiting for it come in. Hopefully everything will be running fine once that's in
 

·
Poopra owner
Joined
·
565 Posts
Well it got the car to start now but there's sill a problem where it's still dumping too much fuel in cyl 3 & 5. I just bought an AEM standalone waiting for it come in. Hopefully everything will be running fine once that's in
check voltage at the ecu for injector outputs. cyl 3 and 5 were giving me issues. if your voltage is low for that output, you need to clean your injector grounds on your intake manifold. that's what fixed mine and it sounds like you're having the same issue now.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #12
Everythings running great now, thank you everyone for Yur help. I'm now running an AEM V2 ems. Just got street tuned yesterday, dyno numbers coming soon :)
 

·
Registered
1987 Supra Turbo R154 Pearl White, Blue Velour
Joined
·
232 Posts
It's a 9 year old post. Maybe they're still involved.
 
1 - 15 of 15 Posts
Top