Supra Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
288 Posts
Discussion Starter #1
Well apparently something has decided to go horribly wrong with my clutch today, at least thats what I think it is. It was acting a little odd the last time I drove it, surging a bit, but tonite it was worse. It started off surging and at one point stalled as i went around a turn going about 5 mph if that. Then, on the ride back home it did the same, surged and then stalled once, but this time it did it while the clutch was engaged and i was coasting up to a stop sign. My clutch fluids looked normal and the check engine light never came up. Basically, with a visual inspection everything looked normal. The only thing that I think could have caused something to go wrong with the clutch was the other day when i was leaving a parking lot, a friend of mine was begging me to light them up a bit and I dropped it from around 4 or so. The car didnt respond too well and surged like it was tonite. Im just not sure. At first I thought it might be a loose ground wire or something to that effect because of these shitty ass roads here in Tucson that throw my car around a bit, but it feels too much like the clutch. Each time that it has surged and stalled is when the clutch was either fully engaged and/or disengaged. If anyone has any advice as to what the hell might be wrong and a solution I would greatly appreciate it. Im gonna try to get it to the shop tomorra or thurs, but I would like to have some input before I head over there. Thanks again

Drew
 
1 - 1 of 1 Posts
Top