Supra Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,400 Posts
Discussion Starter #1 (Edited)
I bought a brand new FJO w/b with the NTK sensor last year. It saw C16 for just the 3rd time Friday night and after my second race with a bike my AF ratio reads 10 at idle when it used to be 13 and when cruising it reads 11's when it used to be in the 14's. I changed spark plugs but it still does the same thing.
I guess this means my sensor died after just 3 times of using C16??

The only other thing that I can think of that could have caused this is on the last race I hit 2.1 bar(I have never boosted this high before) but I only have a 3bar MAP sensor hooked up to the AEM ecu. I remember Justin Nenni telling me when he tuned my car never go past 28psi because the AEM will not know what to do past 28psi.
Since I went to 30psi I wonder exactly what happened?

I need the price for part# S020003. Thanks.
 

·
Premium Member
Joined
·
10,090 Posts
Yeah, on their sensors the discount is non-existant. Its kind of ridiculous, I can barely cover the 3% credit card fee and break even. The rest of their products there is reasonably small discount on, but on the sensors its a joke that they actually expect us to stock and offer these things when we make 5%, and after credit card fees I make 2% (literally).

Regards,

Dusty
 

·
Registered
Joined
·
1,400 Posts
Discussion Starter #8
I wish u would have got back with me sooner! I already ordered one from WOTM
for $248. I could have saved $30.
 

·
Premium Member
Joined
·
10,090 Posts
Well you already knew the price on the sensor was $209.75. Surely you didn't think I was going to charge you $40 to ship a sensor???

I thought it was kind of obvious that regardless of the final price that I would be cheaper than $248.

You can always call me if you're in a hurry and anyone that answers can assist you. Our phone number is in my signature.

Thank you sir,

Dusty
 

·
Registered
Joined
·
1,400 Posts
Discussion Starter #11
Oh well, maybe I still have time to cancel my order. Bad part is I really didn't need it. I called Justin Nenni(who tuned my car) yesterday and told him what happened and his first suggestion was to check the vacuum hose on the FPR. He said when I hit 31psi and let off real quick, the pressure will pop off that hose or other vacuum hoses. Sure enough the FPR vacuum hose had popped off where it connects to the intake mani.
 

·
Boost Junkie
Joined
·
12,635 Posts
Damn dude, invest in some zip ties and put them on all of your vacuum lines.

Steve K.
 
1 - 14 of 14 Posts
Top