Supra Forums banner

1 - 13 of 13 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Ok, now I have NGK plugs (one range colder) in the car and it still pings like mad.

Combustion chambers have been cleaned, new cap/ rotor installed, plug wires tested, injector cleaner used and injector coil resistances checked, O2 voltage checked at WOT, spark checked on all cylinders, and timing retarded as far as 0deg with and without the computer bypassed.

The only thing different from stock is a complete EGR removal and resistor bypass. And nobody else has any problems after blocking EGR?
 

·
Back in Long Island =)
Joined
·
1,449 Posts
does it ping at low idle? Do you hear it? let me know exactly when you see i happen and what not Thanks Brett
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #5
It pings when driving, mainly through 3rd and crusing in 5th. It also pings in 2nd and 4th, but not as bad.

Pings both accelerating and decelerating. Doesn't ping at idle or very light throttle.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Pings mainly at part throttle and a little at full throttle.
 

·
Back in Long Island =)
Joined
·
1,449 Posts
wELL I KNOW WHAT YOUR PROBLEM IS FOR SURE. I HAD SORT OF THE SAME PROBLEM. at full throttle it would hesita not want to go much past 5k now my car revs to 7k no problem any gear. it was the fuel filter. i just got a new filter installed and it made the world of a difference with the top end missing. its all gone
. i guess the reason we had this problem is cause they changed airflow that we created after taking the metal pipe out is really sensitive when it comes to fuel .meaning make sure you have anew fuel filter and you willnt have this problem. it makes sense at full throttle or heavy loads the car has more air but the fuel isnt all there . anyways change the filter and have fun :)

i am positive your problem is about the same as mine and now my problem is fixed. with just a fuel filter. go figure.

~Xdreamer
 

·
Back in Long Island =)
Joined
·
1,449 Posts
another thing you could be hearing is your exhuast pipe
pinging cause its running hotter egt temp with the egr block. are you sure its pinging and not something else. how do you know its pinging what exactly do you hear. ThanksBrett Xdreamer
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #10
No such luck. The timing was retarded as far as it could go with the new plugs in, and it still pinged the same.

It's a metallic pinging/ rattling that gets louder under load, mainly in third, and is light when cruising and decelerating.
 

·
Back in Long Island =)
Joined
·
1,449 Posts
how loud is the pinging? And try changine evrything backto stock seyup and put anew fuel filter. im running stock timing. all i did was put a test pip in the car and change the filter and shes runs perfect and i havent heard any pinging. i use to here the exhuast ticking/pinging. thats why i did the test pipe my second cat was about to go.
 

·
Back in Long Island =)
Joined
·
1,449 Posts
Did you ever figure out what it was?
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #13
Don't know yet. Haven't checked on a fuel filter. Ruled out a clogged cat, though.
 
1 - 13 of 13 Posts
Top