Supra Forums banner

1 - 20 of 20 Posts
L

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I just put a non-turbo 7M in my car, and I think I have a severe lack of power. The car its in is about 3500lbs, but it tops out at 80, and I just think it should go a lot faster. The old engine in it was 115 hp, and its top end was 65. I am thinking it is either a fuel delivery problem, or one of the sensors is jacked. I know the Air Flow meter got water in it once, but I dried it out, could that be it? Also, what is the stock redline, and peak hp rpm for this motor?
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #3
There are no codes, but it might be running rich. Other than getting an air-fuel meter, is there an easy way to tell?
 

·
!black
Joined
·
4,625 Posts
Black smoke, wet/black plugs.

I took a NA mk3 over 100... no reason you should have this many problems.

When you approach the speed limit, what is your RPM? Auto or manual?
 

·
The Old School
Joined
·
230 Posts
rifk how can a car not go over 80 ? Ur all talking like its normal for a generic car to top out at 80.. Anyway, enough bullshit, i think your engine is worn out
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #6
There is a little black smoke at acceleration, but not much. I will pull the plugs when I get home and take a look. I am just finishing getting my tach hooked up, so I am not sure on the RPMs, but it is a manual. As for the engine being worn, it is a JDM take out, and when I replaced the head gasket, the machine shop that milled the head said it was in good shape. As for the block, I can't be sure. Also, this is not really a "car", its a bit bigger, and it used to have a 22RE(4cyl, 2.4l 115hp toyota engine), so I am used to going sort of slow, but at 200+ hp, I expect to go faster.
 

·
Registered
Joined
·
640 Posts
If you would like you could bring it buy my house where are you located. We can take a look at it a little closer. It probably has to do with the fuel regulator . Do you smell like rotten eggs when you first excel? If so that has to do with unloading richa and its actually burning up inside ur exsaust. Where do you live and i might be able to take a look at it.
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #8 (Edited)
I am in school in boulder, but if you would be willing to look at it, i would be willing to drive a little ways. If you would be around this weekend, that would be awesome. I actually had some stuff to do in castel rock this weekend, if your still down there.
 

·
Registered
Joined
·
640 Posts
I am actually not available this weekend but i can do it anytime during this week and mon and tues of next week. Pretty busy sorry. If you want you can schedule something for this week, maybe after your school is out. And ill drive out my SUPRA !! :D
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #10
I only have class from 11-noon on friday, so any time would work for me other than that. Before you commit to this though, I feel I should tell you this motor is in a 4runner, just so your not suprised.
 

·
!black
Joined
·
4,625 Posts
When you are at 80, is the engine turning high RPMs (don't need the tach to hear heh) in 5th?

Are you sure the clutch isn't slipping bigtime?
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #13
No, the RPM's are pretty low, engine is definitly not racing. The clutch is definitly not slipping, its a new centerforce 2, and it never slips even when off the line.
 

·
!black
Joined
·
4,625 Posts
Hmmm.. Does it rev freely when in neutral? Can you take it up through the rev range in 1st, or does it buck/spit when you get higher?

Is this a 4spd or a 5spd? what's the final ratio on that truck rear?
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #15
The tranny is as follows
1st 3.954
2nd 2.141
3rd 1.384
4th 1.000
5th 0.850

And there are 4.10's in the diffs. It reves up pretty evenly, but there is a dead spot around what I guess is the 3-4000 rpm range. I am going to try to get the tach hooked up tonight. Thanks for all your help.
 

·
Senior
Joined
·
1,475 Posts
laoseth said:
The tranny is as follows
1st 3.954
2nd 2.141
3rd 1.384
4th 1.000
5th 0.850

And there are 4.10's in the diffs. It reves up pretty evenly, but there is a dead spot around what I guess is the 3-4000 rpm range. I am going to try to get the tach hooked up tonight. Thanks for all your help.
That spot may be where the butterfly just needs to open. I had my 92 up to 135 on a long highway "down the country". You've definitely got something wrong with your ride-good luck.
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #17
Are you saying that the throttle cable is not opening the throttle all of the way?
 

·
Senior
Joined
·
1,475 Posts
laoseth said:
Are you saying that the throttle cable is not opening the throttle all of the way?
I think the butterfly is vacuum actuated.
Check with the mkiii gurus. They'll probably suggest checking engine codes, etc.
 

·
Registered
Joined
·
640 Posts
Ya my box is full dont know why its empty. I send a email go ahead and give me a call.
 
1 - 20 of 20 Posts
Top