Supra Forums banner

1 - 20 of 58 Posts

·
Over Medicated
Joined
·
2,718 Posts
Discussion Starter #1
Well I finally got everything back together after a month and a half of waiting on parts, broken fans, etc, etc. Some of you know that I had torn my NA-T apart to have the head ported and polished, new Crower springs and retainers installed, new valve seals. I also decided to put in the larger 525cc injectors while everything was apart. I also redid the rest of the fuel rail with a new fuel pressure regulator and a dampener bypass, which I must say looks really nice.
Now most of you will say it isn't possible to run the 525cc injectors without a VPC or AEM but I'm here to tell you it can be done. With the head ported on both the intake and exhaust side and the manifolds on both sides port matched for optimum flow, I'm able to use the Lexus V8 AFM and a HKS S-AFR with the 525's and have a flat A/F ratio of 11.8 over my whole dyno curve.
Now for the rest of the numbers.
At 18psi I was able to put down 471rwhp and 448ft/lbs of torque.:D
If I can figure out how to upload the bitmap of the dyno curve I'll do so.
 

·
Registered
Joined
·
479 Posts
wow Kirk... some good numbers. I can assume you change your headgasket also..correct. what size did you use? Did you drill out the fuel damper, or jst bypass it?
 

·
Over Medicated
Joined
·
2,718 Posts
Discussion Starter #3
I actually already had a Toyomoto 3mm headgasket on that I just cleaned really well and reused. As for the dampener I bought 2 12mm x 1.25 to -6an fittings a 120 degree -6an end and a 45 degree -6an hose end and about 19 inches of braided -6an line.
 

·
Banned
Joined
·
1,890 Posts
Congratulations! I'm curious too... 91 pump gas?
 

·
Built Auto
Joined
·
1,167 Posts
USMC, he's from FL so pump gas is 93 octane there....only you CA boys get the bad stuff ;)
 

·
Registered
Joined
·
273 Posts
Hello everyone, I was there with kbprice the car ran great made great numbers. She definitely has a little more in her look foward to seeing some more.:D I used to own an n/a-T before was fun car R.I.P.:(

I had the same trouble with the bitmap set up,call John, Kirk and see if he can tell you how to do it.
 

·
Over Medicated
Joined
·
2,718 Posts
Discussion Starter #12
I actually had 100 Octane in the tank. But there was more left to go boost wise we just wanted to keep it conservative because of a slight miss that was accuring at about 4000 rpm that we attributed to old plug wires.
Kirk: I emailed that bitmap to you.
Horacio: Autoway Toyota actually had a set of plug wires in stock. I'm putting them on first thing tomorrow to see if that corrects the problem. Thanks again for all your help.
 

·
Registered
Joined
·
273 Posts
Outstanding, let me know if those wires aren't the problem theres something else we can try.


Honestly I think he could of made close to those numbers on pump gas(93 octane)
 

·
I put up BS Flags
Joined
·
1,023 Posts
Congrats and good numbers!
 

·
Hardtopper
Joined
·
13,043 Posts
I wanna see what it feels like sometime man :)
 
1 - 20 of 58 Posts
Top