Supra Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter · #1 ·
I had just put the PI 3800 TC on my car, and after driving about 35 miles I took it to the local track to practice my launches. After about a 15 minute wait in line the car would not move if i touched the gas while in drive and the RPM's would just go up. I have 2 tranny coolers on the car. The car seemed to drive fine before, and I didn't drive it hard to the track. The fluid levels were all good. The TC I bought used from bad94sup and he said it had just been freshened up by PI.
After the car was sitting about 30 min it started up and drove like if nothing had happened for about 10 minutes, then the same thing happened. Had to get the car towed back to the shop.

What could of happened??

Thanks for your help.

Orestes
 

·
Never enough
Joined
·
1,418 Posts
Orestes,

I just sent you a Pm. Check your tranny pump, it may have died causing no line pressure. Did you install the bolts from PI or use the stockers??

Andrew
 

·
Registered
Joined
·
1,421 Posts
Wouldn't a failed stator (pump) in the TC do the same too? Maybe when PI freshened the converter they put a defective one in their.
 

·
Never enough
Joined
·
1,418 Posts
RSA Supra said:
Tranny pump is a likely culprit. Is any fluid leaking out of the front of your tranny?
When I had my level 10 converter, the converter ears on teh input shaft sheered the part that grabs the pump to turn it...didnt notice any leaks, but definietely would not move forward...
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #6 ·
Just talked to the shop and they said it is most likely the pump or a defective TC. They said it would cost about $550 for just the labor. then what ever the pump and fluids cost. This sucks, I had to save up money just to get the thing installed and now this.... How hard is it to take out the tranny? I try to do most of the work myself but just didn't want to ruin anything in the transmission. If I go and get an upgraded tranny from SP or boost logic would it solve this issue, or do those trannies not come withthe pumps?
They used the bolts that PI told my to buy.
And there were no leaks.
 

·
Never enough
Joined
·
1,418 Posts
omr said:
Just talked to the shop and they said it is most likely the pump or a defective TC. They said it would cost about $550 for just the labor. then what ever the pump and fluids cost. This sucks, I had to save up money just to get the thing installed and now this.... How hard is it to take out the tranny? I try to do most of the work myself but just didn't want to ruin anything in the transmission. If I go and get an upgraded tranny from SP or boost logic would it solve this issue, or do those trannies not come withthe pumps?
They used the bolts that PI told my to buy.
And there were no leaks.
Orestes:

Thats a shame man, i dont know what would have caused this?? I doubt it is the TC, but I do believe I still have a year or so left on the warranty so if that winds up being the problem, you'll be ok:cool: Hope everything is ok with the trans! 550.00 is way too much for labor. My first TC i had done cost 300 installed and the pump I believe cost me 120.00 from Elmhurst. When I put my built tranny in, I did it myself on my garage floor and it sucked lol. Do you have access to a lift? BTW the SP and BL tranny's both ROCK!!

Andrew
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #8 · (Edited)
Let me see what else the guy says if not ill have it towed to my house or a storage somewhere until i have enough time or money to work on it... I had to pay $520 to get the TC installed. I will let you know if i need to send it back to PI... How long did it take you to take out the tranny? did you have lots of help?

Thanks,
Orestes
 

·
Never enough
Joined
·
1,418 Posts
omr said:
Let me see what else the guy says if not ill have it towed to my house or a storage somewhere until i have enough time or money to work on it... I had to pay $420 to get the TC installed. I will let you know if i need to send it back to PI... How long did it take you to take out the tranny? did you have lots of help?

Thanks,
Orestes
Took me and a friend a solid weekend (this was our first time) If you have access to a lift, expect it to be a lot easier! I just followed the instructions from www.mkiv.com and there were no surprises. Let me know if you need help with the TC.

Andrew
 

·
Registered
Joined
·
807 Posts
Damn, a weekend? Me and a buddy had my trans out in an hour and a half the other day. First time for TC install took 5 hours. All of this done on jackstands on our backs in my garage. Suck it up guys! :)
 
1 - 10 of 10 Posts
Top