Supra Forums banner

1 - 17 of 17 Posts

·
Your mom goes to college
Joined
·
416 Posts
Discussion Starter #1
well i've been doing my research and i simply cant figure this one out.. About a week ago i set my timing with a not-so-reliable timing light. With the terminals jumped it was reading right around 10degrees. Since then, any time im at a dead stop and hit the throttle, there is almost no response. this morning in fact, i actually had to floor the pedal just to get the car rolling. when the turbo finally spools and hits full boost around 3500-4000k, it gets acceleration back, but not nearly as much as there should be... seriously, from a dead stop it takes probably a full 6 or 7 seconds to make it up to 3500rpms. i'd love to know if anyone has any suggestions..
 

·
Republican
Joined
·
8,421 Posts
well since engines need three things to run (air, fuel, spark) we will go from there
you obviously have air, so it has to be either your timing, or fuel. i would lean twards timing.. very retarded? (the timing that is:p )
 

·
Canada, Eh?
Joined
·
2,397 Posts
are you positive you set timing properly? sounds like you might be set at 0 base, whereas you should be at 10 base.
 

·
***ified?
Joined
·
1,087 Posts
is your wastegate stuck open or easily moved?
 

·
wastegate hose is pulled
Joined
·
4,586 Posts
Me thinks you set the timing wrong. Go back and jump the terminals again. Your check engine light should now be blinking. If it is not, you probably should have adjusted the TPS before checking the timing. ;)
 

·
Your mom goes to college
Joined
·
416 Posts
Discussion Starter #7
1. with terminals jumped there are no codes. i recently replaced the o2 sensor and that took care of codes.

2. im actually not positive i have the tps installed right. all that business in the tsrm was hard to follow. if anyone could point me to a walkthrough on this, i'd try it again.

3. i said the timing light was most likely messed up, because when i connect it to the battery, the engine idles roughly and there is a quiet popping sound (like something arcing inside the gun itself). it was also a little sketchy on the timing position, but seemed to be around 10

4. as for the wastegate. the actuator is held down by the two bolts securely if thats what you mean..

thanks for the help guys..any more ideas? or just elaboration on your suggestions..
 

·
wastegate hose is pulled
Joined
·
4,586 Posts
With the engine running at idle and Te1 jumped to E1 the check engine light should be blinking steadily. This confirms that the ecu is no longer advancing the timing.
 

·
wastegate hose is pulled
Joined
·
4,586 Posts
It's gotta be the dodgy timing light then, unless you changed anything else at the same time.

As long as you :
1. Had the teminals jumped and the engine light blinking
2. Used either #1 or #6 plug wire for the inductive pickup
3. Can clearly see the timing marks on the front cover and crankshaft pully

It is pretty straightforward.

The engine shouldn't run rough just from hooking up the light. It has to be the light.
 

·
Your mom goes to college
Joined
·
416 Posts
Discussion Starter #11
alright dude. thanks for the help. i guess i'll go buy another light and see how that works. if i remember correctly though, when the light worked ok (i think) i couldnt get the timing advanced enough... the cps would not adjust far enough to get the timing to 10degrees. i know i had the cps installed right though... matchmark and hole lined up and put it straight in with the (block)bolt hole right in the middle of the crescent shaped hole on the cps.
 

·
WhorE
Joined
·
504 Posts
If its not your timing I had a similar problem when I replaced the tps, sometimes when you put the tps in it doesn't catch, and it still goes on perfectly.
 

·
Your mom goes to college
Joined
·
416 Posts
Discussion Starter #13
how did you fix it chew? i know i just kinda slapped the tps on there....only later did i realize that there is a certain way to do it. im just still not sure what that way is...if anybody could simplify the process i'd very much appreciate it.
 

·
25psi = 14" brakes :)
Joined
·
2,306 Posts
This is a great thread, I'm dealing with the same issue myself.
The TPS (Throttle position sensor right?) is no longer sending a signal to my ECU. (At least the Eman does not register any signal voltage.)
Also the timing was totally screwed up by the loose timing belt resulting in the intake cams jumping 8 teeth.
I have a new belt in, took the engine to TDC on #1 and made sure the match marks on the cam pullys were right. (Did not check to see if the cam pullys were on the center pin, but I can as I have left the upper cover off till this is resolved.)
The engine runs much better, but now the TPS has no signal, and I'm thinking the timing is screwed up too.
I have a good light, and plan on spending some time getting my car back to pre-Vegas condition.
Any advice here will be appreciated.
 

·
475RWHP 449TQ and climing
Joined
·
5,936 Posts
Tps is the cuplrit if you timed it with te1 and e1 jumped. To see if the tps is working properly take the jumper out of the te1 or the e1 positionwhile aiming the timing light on the crank. You shoud
see the timing advance and recline while doing this. If not adjust the tps or replace it.

Btw make sure you know the differecne between btdc and atdc
 

·
wastegate hose is pulled
Joined
·
4,586 Posts
It is only the IDL switch in the Throttle Position Sensor that has an effect on setting the ignition timing. It must be closed (the IDL switch). When the IDL switch is closed the check engine light will blink steadily while you have the Te1 and E1 terminals jumped and the engine running. If the check engine light is not blinking steadily you are not in base time and your setting will be WAY off. In order to see if it is the Throttle Position Sensor, causing the check engine light not to blink, the IDL switch can be jumped with a paper clip or something.

QWIKSTRIKE's method works just as good with watching the timing when you pull the jumper on Te1 and E1. Whazup QWIK.
 

·
Your mom goes to college
Joined
·
416 Posts
Discussion Starter #17
i know the acronyms for btdc and atdc, but i didnt know it was possible for the timing to be atdc as long as the mark on the crank is in the range of the numbers on the (timing) gauge. i thought that as long as the mark is matching up with with numbers it is before tdc?
 
1 - 17 of 17 Posts
Top