Supra Forums banner
1 - 8 of 8 Posts

·
Impeller Head
Joined
·
2,832 Posts
Discussion Starter · #1 · (Edited)
Interference, should I be worried?

Title should say Interference, not non-interference :)
I just got done putting my long block together; Stock crankshaft, GReddy/Carrillo rods, Jun pistons, Ferrea valve train, HKS 272's. All new shims to set clearances within specs. The timing belt is not installed. With the no. 1 piston at TDC. I cannot fully turn the camshafts, valves hit the pistons. Both head and block were only machined once and not much was taken out. I am also using a stock toyota headgasket. Is there something wrong here? I know this happens with bigger cams and other brands but I didn't think the HKS 272's will cause it. Thanks for any input.
More info on my build up here
 

·
ur moms favourite
Joined
·
1,404 Posts
Im no expert here, but im sure when the engine runs there wont be any problems with interferrence. Unless you get some kinda big valve bounce (which you wont with those springs and a rev limiter), or if the belt snaps.

In your average "non-interferrence" twincam engine, when a cambelt breaks you often get valves bending anyway, not from hitting the pistons, but from intake valves hitting exhaust valves. So "non-interferrence" isnt always exactly what it says.

Thats probably shit you know already, but its my 2c :)

Awesome setup btw, shit thats a bulletproof motor.

Gene

edit: ok i read your other thread, there's definitely nothing i can say that you dont know, good luck anyway, let us know how this ends up :)
 

·
Impeller Head
Joined
·
2,832 Posts
Discussion Starter · #3 ·
Thanks. I didn't think it's a big deal anyway, especially with most of the parts not stock anymore. I just thought I'd ask. Thanks for your input, I appreciate it.

--Ron
 

·
?!!?HABBA BABBA??!!
Joined
·
2,757 Posts
I ran into this same exact issue and thinking the same thing on my build.
 

·
Dr. Jeff Lange
Joined
·
9,352 Posts
Should have let the thread rest in peace, haha.

Jeff
 

·
?!!?HABBA BABBA??!!
Joined
·
2,757 Posts
for what reason? You never know if someone else out there searching is wondering if more than just 1 person has ran into the same issue. Sometimes every little bit helps.
 

·
Impeller Head
Joined
·
2,832 Posts
Discussion Starter · #8 ·
So to close this thread:

Engine is running fine for over two years now. Revving up to 8.5K more than occasionally with no issues. I'm using a power enterprise timing belt for peace of mind and inspect it every time I change the oil.
 
1 - 8 of 8 Posts
Top