Supra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Ok guys, so I installed a NRG wheel, hub and quick release combo on my 95 supra. I had to remove oem clock spring. I cut the 2 wire connector and added relay to avoid airbag light coming on.
I connected the 2 wires (male/female) from hub to 2 wires (male/female) that are on the horn.
After putting everything back together, my horn button is not working.

does anyone have pics of the installation for an MKIV Supra and detailed instructions on how to wire it up correctly so horn can work.

I need use of the horn since there are a lot of stupid drivers in my area.

any help and advice would be highly appreciated.

thanks
 

·
Registered
Joined
·
9 Posts
I don't have an NRG hub but I got my horn to work but my clockspring didn't have to be removed. On the clockspring where the cruise control harness plugs in, the pin all the way to the right is the horn wire which activates when grounded. So one wire connects to that and the other has to be grounded.
 

·
Registered
Joined
·
65 Posts
JZA8DEE is correct. You will need to ground one of the horn wires to the hub adapter. I did so by buying some copper sheet (16 gauge) and made a spring (basically an arc that has tension when the hub is attached. Take a look at the vid I have attached as it will explain everything that needs to be done. It's for an SC but should be similar with a supra since you remove the clock spring. This guys uses a piece of a paint bucket instead of the copper piece I made. https://youtu.be/Sl4Oi-oubRE
 
1 - 3 of 3 Posts
Top