Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
I really need some help. I did all the research on "O/D light flashing" and I got the following diagnostic codes:
42- Defective No. 1 Speed Sensor
61- Defective No.2 Speed Sensor
(both possible short circuit or severed wiring harness)
THE ONE THAT HAS ME WORRIED:
64- SEVERED LOCK-UP SOLENOID (possible short circuit/severed wiring harness?)

My car drives the same that it always has, only now my speedometer doesn't work and my O/D light blinks. Is my transmission going bye bye? I only have 138,000 miles. Maybe just change my tranny fluid?

Thanks in advance!
 

·
Registered
Joined
·
6,907 Posts
Speedometer cable is probably broken (one of the two speed sensors are based on it), and I bet you've got some bad wiring (or grounds).
 

·
There can only be one!
Joined
·
1,604 Posts
my girls n/a auto does the same thing... i think when its flashing the car wants you to put it out of overdrive, kind of like, telling you how to drive it, once about like 60-65mph it stops flashing, because at that speed you should be in overdrive, make sense?

this could be a load of bullshit, but thats what i make of it ;)

mike.
 

·
Registered
Joined
·
59 Posts
I have the same problem with my O/D light flashing in my 88T, and I know that my speedo cable is messed up cuz it squeaks when its cold out, and needle bounce constantly while driving, but I never put the two together before, ill have to look into replacing the cable...
 
1 - 5 of 5 Posts
Top