Supra Forums banner

1 - 20 of 23 Posts

·
boosted for life
Joined
·
103 Posts
Discussion Starter #1
Just a question I keep going through o2 sensors and dont know why. So how far down the exhaust should it be im not running stock turbo and right now its right around where the stock o2 sensor would be. Im just wondering if its to close to turbo.
This might be dumb is the stock o2 sensor the only o2 sensor we can use and does any one know where I could get one cheaper they are exspensive. Thanks any advice would be very helpful
 

·
boosted for life
Joined
·
103 Posts
Discussion Starter #3
wiring is good. It keeps running really rich like crazy it blows so much black smoke but when i change the o2 sensor it runs great. and yes i have a safc and 550cc injectors the fuel is turned down it only runs rich when the o2 sensor goes shitty besides that the car runs great. I just cant figure out why o2 sensor keeps going.
 
F

·
Guest
Joined
·
0 Posts
Tireburner said:
This might be dumb is the stock o2 sensor the only o2 sensor we can use and does any one know where I could get one cheaper they are exspensive. Thanks any advice would be very helpful
I'm pretty sure i have read in previous posts that the mustang sensor can be used.
 

·
boosted for life
Joined
·
103 Posts
Discussion Starter #5
I read that two but was not sure can any one confirm this what year make and model and is that 4cyl 8cyl or what
 

·
1jz-gte motivation
Joined
·
805 Posts
There was just a huge ass post on this...there is a guy on SM selling them for 38 shipped.
 

·
boosted for life
Joined
·
103 Posts
Discussion Starter #8
ok but why do mine keep dieing on me
 

·
boosted for life
Joined
·
103 Posts
Discussion Starter #10
ruthven close to windsor
 

·
Big HP = Big Downtime
Joined
·
2,995 Posts
nice don't see many windsor people on here.

anyway usually if your o2 sensors are failing it means your car isn't running right. If its running very rich its fouling up the sensor until it can't read anymore. Is it tuned up and running properly?
 

·
1jz-gte motivation
Joined
·
805 Posts
Do you have any type of fuel management or Fuel regulator? Stock injectors?
 

·
Registered
Joined
·
542 Posts
Orubus said:
Do you have any type of fuel management or Fuel regulator? Stock injectors?
Tireburner said:
and yes i have a safc and 550cc injectors the fuel is turned down it only runs rich when the o2 sensor goes shitty
reading before you post is a good thing :rolleyes:
 

·
1jz-gte motivation
Joined
·
805 Posts
And being derrogative will get you help...Fist yourself. :rolleyes:
 

·
Registered
Joined
·
409 Posts
enough with the bullshit boys, back on topic. how do you know when your O2 sensor goes bad?
 

·
Registered
Joined
·
542 Posts
When you get shitty gas milage, your running really rich (i.e. black smoke comming out exhaust), or you get code 21 telling you its bad.
 

·
Not ur jizz, not ur bizz
Joined
·
6,571 Posts
ladmo said:
When you get shitty gas milage, your running really rich (i.e. black smoke comming out exhaust), or you get code 21 telling you its bad.

when you get 230 miles a tank..thats when

as for code 21, yes its an indictor engine light for the o2...only really happens when it isnt plugged in :)
 

·
Premium Member
Joined
·
6,130 Posts
Play nice guys and stay on topic! and check for IC leaks and a good ignition system cause running rich can also damage your 02 sensor... aight peace :chicken:
 

·
Savage Member
Joined
·
1,033 Posts
I get 220 Miles per tank...with 550's/lex.... Does this mean I need to change mine? I haven't ever so...............=)
 
1 - 20 of 23 Posts
Top