Supra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5,231 Posts
Discussion Starter #1
Okay, so I changed the O-ring to the oil-filter bracket and we still have an oil leak below the intake plenum on the 94 NA/auto.

While I was doing this, I felt a hose that came along underneath the plenum and figured it may be an oil return hose and maybe that's what needs replacing. However, when I asked about an oil return hose on that side of the engine, the Toyota parts person didn't seenm to have a clue. Can anyone tell me what else might be the oil-leak culprit on the driver's side of the engine??? :dunno:

TIA!
 

·
TT This
Joined
·
917 Posts
There are no oil return lines on the NA engine. The only things that could cause oil leaks on the intake side are the pressure sensor, oil filter and/or oil filter bracket and the huge bolt that holds it on, or it's coming from the valve cover on that side and leaking all the way down the block. The only hoses underneath the intake is the fuel return line and a few vac lines farther towards the fire wall... good luck man :x:.
Or it could be the oil pan...
 

·
Registered
Joined
·
5,231 Posts
Discussion Starter #4 (Edited)
Looks like it's coming from way above the oilpan... I tightened the valve cover when the GF 1st got it and have since replaced that O-ring. Gonna remove the intake this next weekend and see what else it may be. That oil-pressure sender may be the culprit, but the GF wants to do some polishing anyways. So, I'll remove the intake to fix this issue and replace the plugs while I'm at it (and she can make it "shiny" before I put it back on ;-). Thanx!!!
 
1 - 4 of 4 Posts
Top