Supra Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,343 Posts
Discussion Starter #1
I don't know whom to ask anymore, so I figured I'd shoot you guys the question.

A friend of mine blew his stock bottom end top of third on the revlimiter (6speed). T51R Kai turbo and all that jaz. After the engine let go it still ran, but with 100PSI of oil pressure at idle. After tear down it was determined it crankwalked, and spun a bearing.

Head was sent out cleaned/freshened up, new Yota short block, new oil pump, new gaskets, new everything.....problem..... Car starts first crank with new everything but it still idles at 100-110 psi of oil pressure. Changed oil pressure gauags, and both the Greddy electric and the NAPA mechanical read the same. Oil passages were checked and oil cooler cleaned and checked.....

Any help is appreciated. Anything he can test would be appreciated.

Thanks,
Alex W.
 
B

·
Guest
Joined
·
0 Posts
when you first start your car the oil presure will be high. i see 7 bar (101 psi) when i first start my car then it slowly starts to drop down to 3 bar (43 psi)
 

·
Banned
Joined
·
588 Posts
Boostinhard said:
when you first start your car the oil presure will be high. i see 7 bar (101 psi) when i first start my car then it slowly starts to drop down to 3 bar (43 psi)
true, the oil is still cold and thick.
 

·
Registered
Joined
·
183 Posts
What psi should the oil pressure be at when warm and at idle then?
 

·
Premium Member
Joined
·
11,271 Posts
OVRBST said:
I don't know whom to ask anymore, so I figured I'd shoot you guys the question.

A friend of mine blew his stock bottom end top of third on the revlimiter (6speed). T51R Kai turbo and all that jaz. After the engine let go it still ran, but with 100PSI of oil pressure at idle. After tear down it was determined it crankwalked, and spun a bearing.

Head was sent out cleaned/freshened up, new Yota short block, new oil pump, new gaskets, new everything.....problem..... Car starts first crank with new everything but it still idles at 100-110 psi of oil pressure. Changed oil pressure gauags, and both the Greddy electric and the NAPA mechanical read the same. Oil passages were checked and oil cooler cleaned and checked.....

Any help is appreciated. Anything he can test would be appreciated.

Thanks,
Alex W.

100+ psi is normal for a cold 2J motor!!
 

·
Inline for the win
Joined
·
4,727 Posts
Mine is around 100 at cold and 36psi at operating temp at idle. 2-4k Rpms under load while at operating temp, I see 55-60 psi of oil pressure.

I was wondering about this, also.

Larry,

Did you by chance do any testing before and after on car with oil pump modification to see the differential of pressure at WOT?
I was pondering if there is a difference that someone has documented. Also, does the catch can install versus dumping to the atmosphere with a k&N reduced high oil pressure at WOT?


DP

P.S. I am still waiting on the reply for the information on the turbo setup for that Typhoon I emailed you about a month ago.

Also, tell Tim I am awaiting that quote on upgrades, too.
 

·
Registered
Joined
·
183 Posts
I apologize for jumping into your thread OVRBST. I tried to get similar information in a different thread, but yours is turning up much more info. :)

I've seen my oil pressure drop to as low as 8-10psi at idle (while warm) recently. Also, I'm been fighting an oil leak that apparently originated from the relief valve on the oil pump over the past month.

Do you think these two issues are related or simply coincidence? Should I be expecting a faulty oil pump is the cause? Any help at all would be greatly appreciated. I'm to the point where I'm considering pulling the engine to either have built or buy a new built one.

Thanks in advance guys!
 

·
Registered
Joined
·
1,343 Posts
Discussion Starter #9
Thanks for all the help. Its seemed odd that 100+ psi of oil pressure is normal, but after starting my own car yesterday I actually paid attention to the oil pressure and sure as hell, my own car had 8.5bar of pressure (~120psi). Always comes right down, but still freaked me out when someone says 100+ psi at idle.

Thanks again,
Alex W.
 
1 - 9 of 9 Posts
Top