Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
You guys with oil temp gauges, where do you mount the sender unit? Anyone use a drain plug temp sender?
 

·
Buddy thought I had a NA
Joined
·
2,463 Posts
just run it in the stock laction easy said and done tell you try to get he stocker off heheh i still have nto yet to do that instead i just wired it into my stock sender does not work well caus ehte auot meater sender puts out bigg restaince
 

·
Registered
Joined
·
1,437 Posts
NashMan said:
just run it in the stock laction easy said and done tell you try to get he stocker off heheh i still have nto yet to do that instead i just wired it into my stock sender does not work well caus ehte auot meater sender puts out bigg restaince
:scratch: Stock location? I haven't seen where the 7M has an oil temp. gauge stock.
 

·
25psi Bliss
Joined
·
1,446 Posts
Observed Oil Temp variations:
- At cold startup and idle, oil temps would not exceed 170degF.
- During cruise, oil temps would vary between 150 - 170 depending on ambient temps.
- Upon coming to a stop, temps would increase to ~210+degF.

This was observed with my *external* oil pump / cooler malfunctioning. Since I've capped off the stock oil cooler routing, then my car was essentially operating as a normal 7MGTE would and I'll expect similar temps with a car with existing OE oil cooler setup.

Since then I've completed my oil delivery / cooling mod: External / relocated oil filter + Setrab oil cooler + oil thermostat + accusmump, I've seen temps increase to 170degF at cold startup, hover around 150 - 160 at cruise, and increase to about 165degF at idle after a long drive or any spirited driving.

HTH,
Howard.
 
1 - 6 of 6 Posts
Top