Supra Forums banner

1 - 20 of 21 Posts

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #1 (Edited)
Old video from when I was NA w/ nitrous + some NA-T videos

I was looking through old files and came across this......... can you guess when the nitrous kicks on? :bigthumb: this was only a wimpy 60 shot but it made a hell of a difference when it was NA!

I am now NA-T with the same motor for over a year with no problems...

http://www.clubna-t.com/videos/kirkMKIVslow.avi

here is another video from when I was NA-T (my old SP57 on 10psi) on that same road...car just spun tires but it sounds cool.... :bigthumb:
http://www.clubna-t.com/videos/kirkMKIVslower.avi
and another one while i was NA-T
http://www.clubna-t.com/videos/kirk.avi
 

·
Registered
Joined
·
479 Posts
i remember the nitrous video from when i was debating if i wanted to use nitrous too.. sick videos. cant wait to see new videos with your new setup
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #4
Ryan_F said:
The requested URL /videos/kirkMKIV.avi was not found on this server.
fixed :bigthumb:
 

·
Addicted to Boost
Joined
·
315 Posts
You ever dnyo it with that nitrous and see what kinda number it adds when sprayed?
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #6
TRD4Life05 said:
You ever dnyo it with that nitrous and see what kinda number it adds when sprayed?
Yea

NA: 174rwhp
NA w/ 60 shot: 235rwhp
NA-T @ 10psi: 390rwhp
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #7

·
Registered
Joined
·
696 Posts
lol that passenger was psyched. I liked that last one. You need to run him again with the nat, then it's c-ya Vette. :)
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #9
Ryan_F said:
lol that passenger was psyched. I liked that last one. :)
Yea.. the owner of the vette just sent me this video on my other forum.. trying to show me that he beat a turbo supra............ :lol: I was like WTF thats me!

I only sprayed to get to 130ish mph and turned off the nitrous on top end when he started reeling me in... the supra was running out of gearing by then which is why he started gaining on me. Not bad for a little ol' NA :chicken:
 

·
BoosT AddicT
Joined
·
238 Posts
that bridge looks a little familiar... *cough gandy cough* nice vids..
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #11
ding ding ding ding we have a weiner.... :lol:
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #16
streetraser2002 said:
dam kirk, didn't know you hit 390 at only 10psi. which turbo was that with?
sp74, 440cc injs, stock fuel pump, vpc/safc2 thats it.
 

·
Always on call
Joined
·
1,928 Posts
That sure was a powerful 60 shot......heard you got it for a good deal too heheh. :)
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #18
DrDJDesi said:
That sure was a powerful 60 shot......heard you got it for a good deal too heheh. :)
yea from some doctor that used the bottle to get high off of it :scratch: :lol:
 

·
Registered
Joined
·
103 Posts
so kirk when did you have the nitrous activated, in what rpm range, when u were taking off in first, the revs sounded like they just went crazy when u got past 35000 but its hard to tell, was it smooth powerband, details plz im interested
 

·
Hardtopper
Joined
·
13,043 Posts
Discussion Starter #20
I had it activate around 3500-4000 and shutting down a little before redline.... I never had the nitrous activated with the RPM's less than 3500... powerband was smooth.... it's like a turbo coming on full boost instantly without the lag. It was definately the best bang for the buck as far as going fast on the NA went... motor was perfectly fine and still is fine after many bottles :)
 
1 - 20 of 21 Posts
Top