Supra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
748 Posts
Discussion Starter #1
hello all, i have a 95 n/a with about 130k on it. so far it's been running good until a couple weeks ago. when i would start up the engine, a huge puff of smoke would come out my exhaust and i'm loosing quite a large amount of oil every week. what could be the problem? could it be the pisting rings...
 
Z

·
Guest
Joined
·
0 Posts
if NA and turbo engine uses similiar parts, then it could be the valve stem seal. yes its buring engine oil, so check your oil level regularly. it shouldnt effect performance, heard it cost around $1000 to get it fixed by Toyota.
 

·
My mind is forged
Joined
·
895 Posts
Make the pressure test and oil leak test, (10-15$) than you will know for sure.
 

·
We has your money!
Joined
·
576 Posts
asdf

na dont have an intercooler...could be your rings or valves..get a leakdown or compression check.
 

·
Registered
Joined
·
458 Posts
DOH! I should've read more carefully, thanks for catching me on that one...

I guess it's gotta be valve stem seals then... Might as well yank the head, send it to Extrude, then do larger Ferrera valves, springs, retainers, and a single turbo kit so you can have a big-ass FMIC in the grill!!! :D
 
S

·
Guest
Joined
·
0 Posts
If the huge amount of smoke is just at startup or sometimes when u stop and idle for few and take off ( a smaller amount ) but mostly when you first start the car.. it's definitely valve seals.. might as well change the cam seals while your at it. Dealer fixed mine and it cost me 1,045 bucks, had the hookup somewhat ( they even tossed in a new belt and install for my crank. Fixed the problem immediately.
 

·
Registered
Joined
·
748 Posts
Discussion Starter #8
well, i think i'm going to get the whole engine rebuilt while the car is at the body shop. i wasn't going to get the engine bay repainted but it looks like i might do so. might as well get the engine rebuilt while the car is out of commision.
 
1 - 8 of 8 Posts
Top