Supra Forums banner

1 - 11 of 11 Posts
L

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I've already searhed for this on the forum, but can't find a solution anywere. My overdrive light starts flashing on and off. The transmission shifts just fine and nothing appears to be wrong. I was wondering if anyone knows what causes this or what a solution to this is.
 

·
Registered
Joined
·
532 Posts
man mine does the same thing, it blinks every 2 sec. i bought the car that way. noone here knows what it is, but my car works just fine so im not really worried about it. just curious, is your manu mode not functioning also??
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #5
My manu mode works just fine....I'm just wondering if it's worth taking to a mechanic to look at. So far I don't think anyone has had anything problems despite this. How long has yours been doing this?
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #6
BTW....what color is your supra aznsupra? Do you ever go to the starbucks on post oak on Sat. night?
 

·
Registered
Joined
·
532 Posts
i bought my car at 29620 miles....it currently has like 32200 or so, its been doin it the day i bought it, and it still does it. one person told me to pull the light out, but im not really all for that. i really wish i could help you with it, but i havent a clue what it is. i even got a supra tech/shop book that covers the entire tranny. that didnt even help. but honestly im not worried about it, my car drives very good. did yours just do it all of a sudden??
 

·
Registered
Joined
·
532 Posts
oh damn i didnt even see that youre from houston...yes i go sometimes.. like once every 2-3 weeks. i seen everyones supra with nice rims etc, and mine on the stock silver wheels :rolleyes:
i felt like such an outcast lol. but i finally got wheels, just w8in til i have time to install the eibach /kyb. i have a red supra,
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #9
yeah, I don't know if I've seen you out there before, but I drive the White Supra....still on stock wheels so don't worry, you're not the only one. I'm not getting rims till I get my body kit later this year.
 

·
Shawn Davis
Joined
·
1,662 Posts
I thought the blinking light was an indication of an overheating condition in your transmission. I know that when the transmission overheats one of the lights (either manu or O/D) blinks as you described. I think I read this in the new car feature manual on mkiv.com.
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #11
Mine has done the same thing since I bought it 2 months ago. I had a Toyota tech run the codes on it and it pulled up the upper speed sensor. That explains why my cruise control doesn't work. :rolleyes:

Not saying that this is what's wrong with anybody else's Supra but, if your cruise control doesn't work this is probably it.
 
1 - 11 of 11 Posts
Top