Supra Forums banner

1 - 19 of 19 Posts

·
Making a ComeBack!
Joined
·
1,058 Posts
Discussion Starter #1 (Edited)
So my rear CAM Sensor was cracked, leaking oil, and looking aged, it was just in bad shape.
I decided to try the PHR Billet CAM Sensor delete for 2jzgte which would work for me Since the AEM only reads the front Cam sensor....

The fitment was GREAT and the O-ring fit right in place (Had to put a LITTLE bit gasket maker around the O-ring to keep it in place) but other than that i'm happy. I went for a test drive came back checked it and no leaks and no issues on the test drive.

Ohhh and it fits in very well with the bay and made it a little more cleaner.

Thanks guys. ;)
 

·
Registered
Joined
·
44 Posts
can you keep the rear cam sensor and delete the front one? The front one makes it hard for my center fuel return fitting to fit. this would be awesome if it did. I also have the titan fuel rail with ID1000cc injectors. I just assume that what you have since its similar looking.

If youre wondering why mine is hard to fit is due to the fact I have an -8AN fuel return line per my weldon fuel pump requirement. I had to weld up and make my own fitting to clear it..what a PITA!

BTW, looks good on there!
 

·
Registered
Joined
·
44 Posts
Affirm, AEM V2. not tuned yet but soon. THX for the Good info on the rear sensor. I will pick one of these up and ditch the front sensor. This is awesome news.

^^^I also have issues with powerhouse website on my droid.

EDIT: is the OP using the wrong sensor since he deleted the rear and now only using front..? he is AEM tuned right?
 

·
Registered
Joined
·
355 Posts
Affirm, AEM V2. not tuned yet but soon. THX for the Good info on the rear sensor. I will pick one of these up and ditch the front sensor. This is awesome news.

^^^I also have issues with powerhouse website on my droid.

EDIT: is the OP using the wrong sensor since he deleted the rear and now only using front..? he is AEM tuned right?
You can use either sensor on the AEM. AEM default is set to the FRONT sensor. If everyone reminds me next week, I'll post the settings for getting AEM to use the rear sensor.
 

·
Inline for the win
Joined
·
4,697 Posts
IIRC, if you choose to use the rear sensor over the front sensor, you may need to reverse the wiring to the AEM to get the proper wave form. The cam sensors are polarity dependent, FWIW.

DP
 

·
Making a ComeBack!
Joined
·
1,058 Posts
Discussion Starter #12
Suprafied let me ask this... is it posible to just extend the connection for the front to the rear and it works?
just asking, i'm good with mine i'm not using the middle return on my fuel rail so no need for me.
 

·
Registered
Joined
·
355 Posts
IIRC, if you choose to use the rear sensor over the front sensor, you may need to reverse the wiring to the AEM to get the proper wave form. The cam sensors are polarity dependent, FWIW.

DP
You don't need to do any rewiring. Just change the tooth firing order for injector and coils. (Coils actually won't have to change at all on V1, being wasted spark).
 

·
Registered
Joined
·
1,856 Posts
Hi Bryan,

You had posted in a thread in 2012 that you would post the aem setting that would allow to run aem v2 with the front cam sensor deleted. can you please help me? I purchased the delete, but now my car will not fire up. I'm not sure which setting to change in AEM. Any help would be much appreciated.
 

·
Registered
Joined
·
1,856 Posts
Thanks, Bryan. I messaged you back with my email address for the screenshot but haven't received it yet. Can you please send when you can?

thanks!
 
1 - 19 of 19 Posts
Top