Supra Forums banner

1 - 4 of 4 Posts
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #1
EGt ran 740-760 degree at top of downpipe doing a hard pull to 130+mph.

I have ordered new fuel pressure regulator and have the fuel controller ready to be dynoed. could there be anything else?
the car drives fine at any speed, fuel economy is good too.

I am kinda thinking abou thte fuel pump, what are the symptoms of bad fuel pump? what about that ECU that controls the fuel pump? anything else I should check?

thanx

Jonas
 

·
Registered
Joined
·
1,022 Posts
Why not just get a fuel pressure gauge? That would tell you if your FPR or pump isn't working. You could just get a cheap autometer one and take it out when you are done. If you have good fuel pressure put it on a wideband and see what your A/Fs are.

How much boost are you running on that piss-gas? Have you tried turning it down to 16 or so?

BTW I just did a compression check, they were all 172-177 :p My EGTs stopped moving at 670C, even up to 162 mph. But thats on 6097s which are one heat range colder than stock.
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #3
congrats on the good compresion #! strong car!

yeh I think I will do that. is it hard to install fuel pressure gauge?

I did turn down the boost to 16 but I still hit 700 on hard pull so I just let off.
 

·
Registered
Joined
·
1,022 Posts
700 is still kinda high IMO. Better safe than sorry.

I don't know how to install a fuel pressure gauge. I'm getting a wideband soon anyways :)

Mohd mentioned how to test the FPR with fuel pressure, but I can't find his post now. I'm sure its in the service manual. From what I understand a few people have had their FPRs go bad, and have similar EGTs to yours. Kind of a scary thing to go bad!
 
1 - 4 of 4 Posts
Top