Supra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
827 Posts
Discussion Starter #1
Here's the deal:

I believe I have a 3 psi boost leak for the following reasons:

1. With an RMM dp, I only hit 11 psi max boost.
2. I've tested my mechanical boost gauge with a controlled pressure source and it is accurate.

What I've done to diagnose so far:
1. Did the TTC mod = no change; same boost. This supposedly elimates problems with the egc and iac vsv's?
2. Checked stock BOV = no visible oil leaking
3. Visibly checked all hoses visible from to of engine bay = I found a loose EGR hose? and replaced it. No change in boost.

The only mods I have on the car are in my signature. Before the RMM dp installation, I was getting 9 psi. The leak is something recent, because I used to get 11 psi with no mods all day long.

Any advice?
 
K

·
Guest
Joined
·
0 Posts
I had the same problem my trouble was a vsv vacuum line was switched the pressure would hit then drop off taking the second turbo off line.... the ttc temp mod sucks... if everything isnt perfect it wont work at all i hoofed my number one trying it.... the vsv that was switched was the one in the front make sure it is working by removing it and testing with battery one pos and one neg doesnt matter which put a pressure tester on the vsv and touch to battery should hear it switch.... any more info email ill try to help i know how tough these problems can be didnt find mine till i hoofed the turbos... Kevin.
 

·
SpooooL
Joined
·
591 Posts
I have the TTC mod on my auto. I did it because I could not get any more than 10psi. Could it be my actuators causing the 10psi trouble? The TTC mod sucks on my auto unless I do WOT from a stop. If Im on the interstate, it will rev up to about 7000rpms and then MAYBE kick in. What steps should I take? How exactly do you test the actuators? Thanks in advanced.
 
1 - 3 of 3 Posts
Top