Supra Forums banner
1 - 20 of 30 Posts
G

·
Discussion Starter · #1 ·
Hey sorry i forgot your name.. just wanted to say thanks for pulling over and helping us.. we got the car towed just to be sure. I have someone come over tomorrow and look at it to see if he can help find out the problem.. car idle did go up, but still when i went beyond 4000 rpms or higher once i let off the gas the car would stall again. Once again thanks for your help and i hope yall made it home safely.
 
G

·
Discussion Starter · #4 ·
Hey Junito! my name is Jim Yea i still think its the turbo, just because the way it was smoking, but definately let me know what the deal is with it! u can IM me on AIM at Importsupra95
 

·
Registered
Joined
·
2,561 Posts
Damn dude....that blows!!


Is this after you just had the rear main seal replaced cause it blew after the Turbo install?
 
G

·
Discussion Starter · #7 ·
WhiteBlazze said:
Damn dude....that blows!!


Is this after you just had the rear main seal replaced cause it blew after the Turbo install?

yup.. i have no idea what the problem is now!
 
G

·
Discussion Starter · #8 ·
you need to take the car back to the dude the put the turbo on and tell him to fix it rite u had nothing but problems since u got the turbo on :sadwavey:
 
G

·
Discussion Starter · #9 ·
hey jim... i took off my intake and everything b4 the turbo.. and it runs w/o stalling. i think the maf is going bad
 

·
Registered
Joined
·
3,688 Posts
Definitely sounds like the MAF sensor going bad. I have a spare one from my TT car if you wanna try it out to confirm. Or now would be a good time to go VPC.
 
G

·
Discussion Starter · #11 ·
AlpineTT said:
Definitely sounds like the MAF sensor going bad. I have a spare one from my TT car if you wanna try it out to confirm. Or now would be a good time to go VPC.

im having it looked at tonight. if you like pm ur number and ill give you a call if we think that is the problem
 
G

·
Discussion Starter · #12 · (Edited)
G

·
Discussion Starter · #13 ·
Damn, well thats good its simple...i'd definately go VPC instead of going back to the MAF...when you have the MAF off does it still shit out smoke? Lemme know what the deal is...
 
G

·
Discussion Starter · #14 ·
TTSupraMan93 said:
Damn, well thats good its simple...i'd definately go VPC instead of going back to the MAF...when you have the MAF off does it still shit out smoke? Lemme know what the deal is...
its not really smoking ne more. its just when i press the gas the shit ends up on the ground.. i dont see it come out. its there when i stop. but not much smoke at all
 
G

·
Discussion Starter · #15 ·
Well those little particles could possibly be buildup in the exhaust...But let me know what happens when u find out!
 

·
LexusTico
Joined
·
3,172 Posts
Hey what's up? I've got a MAF for sale for $60 shipped if you need it. I just took it off my car for my single install.

let me know and I'll box it up for you.

it's a lot better than $500+ for a vpc.
 

·
Vengeance is mine
Joined
·
907 Posts
That sucks man...... might have been a good idea to keep it local for the first few miles... i know how it is to be excited about the car though...hope it works out.
 
G

·
Discussion Starter · #18 ·
TTSupraMan93 said:
Well those little particles could possibly be buildup in the exhaust...But let me know what happens when u find out!
yea ryan was nice enough to come over and check it out... he also thinks its the maf
 
G

·
Discussion Starter · #20 ·
AlpineTT said:
If you need a MAF sensor to test, give me a call tommarrow after 12 at 443-610-3934.

Alex
ok thanks alot alex.. im in owings mills ill give you a call 2morrow.. thanks again
 
1 - 20 of 30 Posts
Top