Supra Forums banner

1 - 4 of 4 Posts
7

·
Guest
Joined
·
0 Posts
Discussion Starter #1
alright, well my head gasket is starting to go out...whats new, i know...lol!! But i was thinking maybe i just didnt tourqe it down fully so i ripped everything apart and retourqed the head bolts and they were a little loose. I put everything back together and car idles high...like around 2000rpms...i let it run for a few minutes to see if maybe it just needed to warm up or something but a few minutes later i notice water spraying out of the radiator hose where it connects to the thermostat housing. tighten that clamp down a little more and it stops leaking. But then water pours out of the over flow.....then i notice water coming from around the neck on the radiator, right below the cap, look at temp gauge and its getting hot...about 3/4 of the way up so i turned the car off and stood there scratching my head..lol!! So what could be the problem? Is it possible the thermostat is stuck or bad radiator cap..causing pressure to build up causing the leak on the hose and the crack in the radiator? what about the high idle?
sorry for the long write up but i tried to get as much info in as possible oh and the car is an 87 with a recently installed jdm engine that ran fine since december.......
 

·
Banned
Joined
·
2,386 Posts
could you have air in the radiator system..that needs to be escaped..?
 
7

·
Guest
Joined
·
0 Posts
Discussion Starter #4
OMG.....my car runs so much better now since i retourqed the head bolts!! It runs smooth and pulls hard!!! Man i didnt know i was missing this much performance..lol!! I guess ehen the head gasket was done the first time it wasnt tourqed down completly for some reason or another??? but since i did that it runs awesome!! Oh and i just toook the thermostat out because even after burping the system it still got hot. So it looks like its time for a new T-stat!! Just been out driving for like an hour enjoying my new found power :)
 
1 - 4 of 4 Posts
Top