Supra Forums banner

1 - 4 of 4 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Couple of quick questions.

Car is BPU; HKS intake, RMM DP w/high flow cat, Apex'i N1 exhaust, GReddy BCC and Blitz DSBC.

With gain set at 9 and ratio at 77, I only see .65 BAR on the first turbo and 1.22 BAR on second turbo with boost dropping to .6 BAR during 1st to 2nd turbo transition. (tested in 2nd gear)

Is this normal? If not, what kind of boost pattern do you usually get and at what setting?


With the DSBC off, what kind of boost pattern are you getting? I've been told that even with it off, BPU owners should expect 1 BAR on 2nd turbo, but I can only get .75 BAR on second and .55 BAR in first with the unit off.

What kind of vacuum reading is showing on your display? Mine says -46 when car is in neutral.

Trying to compare notes so I can fix the boost leak I've been trying to fix for the past couple of weeks. Thanks!

-Rudy
 

·
Registered
Joined
·
192 Posts
That actually sounds very good. 1.2 bar on stock twins is pretty high boost... Mine stock twins could only peak at 1.3 bar maxxed out (i am at high altitude tho) so yours sounds about right at 77%. I had my gain set at about 23 tho.
 

·
Registered
Joined
·
207 Posts
When I was going through my boost leak phase with the DSBC, I was only able to hit 0.79 kg/cm^2 and max boost at 5000 rpm was only 1.05 kg/cm^2 and from there it slowly drops down to 0.84 kg/cm^ near readline.

Max boost 1.05 kg/cm^2(a little bit over 15 psi) is about what a car would make with just BCC/dp/exhaust. It got me thinking there was something wrong with the turbos or the DSBC. A quick way to eliminate to turbos was a trick I learned from Andi B. :), I temporarily remove the
cap from the bottom of the wastegate actuator. This effectively keeps the wastegate open and give you maximum boost. I went on WOT didn't go past 5500 rpm, if the turbos are healthy you will see about 1.46 kg/cm^(Blitz DSBC peak hold comes in handy).

To make a long story short, I eventually tracked the problem down with the electrical connector of the soleniod. One of the pins came loose from the body of the connector and was not making contact, the boost controller was essentially turned OFF.

Since I have fixed the problem, with GAIN=5 and Ratio=72, I could hit ~0.9 kg/cm^2 with the 1st turbo and 1.3 kg/cm^2 hitting boost limit(boost limit set to 1.28) with the 2nd turbo.

At idle, my vacuum reads -43 .
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Found a popped hose near the manifold area. Secured the vacuum hose and the boost jumps to 0.79 1st turbo and 1.27 for second turbo. :D

The 1st to 2nd transition still drops too much. Boost drops to .6 Bar then spikes to 1.2 when the second turbo hits. Is this normal?

-Rudy
 
1 - 4 of 4 Posts
Top