Supra Forums banner

1 - 9 of 9 Posts

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Discussion Starter #1
Just curious. I asked this before and didn't really get any info on it.
On the tops of the injectors there is a bar that bolts across them. I guess to hold them in.
What is the deal with the o rings up top? Does that bar seal anything, or just helps hold the injectors in the rail?

I ask because I saw this pic the other day and I am having some breaking up problems and thinking about my injectors install now
 

·
Not so boring anymore
Joined
·
7,085 Posts
hmm...... interesting.. i havn't seen that, but after I put my injector back in from forgetting 1 of those bolts that hold it in it started to miss.....
 

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Discussion Starter #3
really? Did your injectors fit snug against that retaining bar?
Maybe that is part of the reaston my car is breaking up?I had a slight gap.
 

·
Not so boring anymore
Joined
·
7,085 Posts
I didn't look, but I lost 1 of the 3 bolts that hold that bar on or it backed out when driving or something, so an injector started to pop out (sprayed gas all over :( ), but when I fixed it I never checked to see if there was a gap. Im not sure if there was a gap to begin with iether, I never checked.
 

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Discussion Starter #5
IM not spraying gas anywhere. I know that much. But I am curious as to if that tiny ass gap will cause enuff problems to push the injector out?
I also found cracks in all my coilpacks and replacing those this weekend. I guess thats the next thing to look at.
 

·
JZA is best f**k the rest
Joined
·
351 Posts
Mine didn't fit flush either, I think the whole purpose of the piece is to keep the injectors from popping out if it didn't seal correctly :dunno: Mine looked the same and sealed fine.

Jake
 

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Discussion Starter #7
thanks.
Maybe Im lucky/unlucky enuff that its just the coil packs arching on my head causing my breaking up.
 

·
Not so boring anymore
Joined
·
7,085 Posts
No.. If you look there are 2 bolts on the 123 injector holder rail peice thingy (lol) close together then one next to injector 1.. The bolt next to injector 1 was gone, i was trying 15 psi, 1/2 way through 3rd gear broke up so i got off of it.. I was 1/2 a mile from home, so just drove home.. got home turned the car off and heard a water like noise hitting the ground opened the hood gas was spraying everywhere (havn't wired up the fuel pump properly yet with the aem, so stays on 10-15 seconds after the car is off till main relay is switched off) , turns out boost pushed the injector out and bent the injector bracket peice.. ever since i put it back together it misses when i touch the gas, fine under boost and crusing.. just misses when i touch the gas.. when i put it back together i didn't check to see if there was a gap, and if that is a problem maybe why it missed, but i guess its probably not..
 
1 - 9 of 9 Posts
Top