Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I just got my car back from the mechanic, after my supra got a tune up and oil change, etc. He siad he put a slow charge ont he battery because it had to be jump started to get there. I was running fine all day. the car could turn off and back on with no problems. I got to my girlfriend's house, and turned off the car on the driveway. Now when i was leaving i tried to start it, and the battery is low again and the car wont start. The interior lights all come on and stuff, but just barely not enough energy to start the car. What should i do? If i leave it for a few hours will it recharge? Should i jumpstart the car again, and if i do will it die on me the next time i turn it off? What can i do to fix this?

And since im on a budget i dont really want to buy a new battery, and a slow charger I hear they are quite expensive, i am looking for other alternatives.
any suggestions and help would be greatly appreciated.

cheers,
Chris
 

·
HKS T51R
Joined
·
2,732 Posts
yeah, you need a new battery, i would reccomend a optima red top battery. One of the best car batteries ive seen yet. If you really low on cash just jump it and keepthe car running for abit, and see how long it keeps its charge, if it doesn then its toast hlh
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Lets say i jump start it and get home, and park it for the night. any chance it will run tomorrow, and the battery stays charged?
 

·
Boost Addict
Joined
·
622 Posts
you may also want to check for power drains -- a light stuck on or some such. But it does sound like the battery's shot.
 
1 - 7 of 7 Posts
Top