Supra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hi all,

I am having an intermittent rattling issue after putting the car in TTC. It seems to occur in the passenger side of the engine bay, and the sound seems to rattle down into the exhaust system. The reason why the car is in TTC is because of the lack of boost. I would not go above 10 PSI, then would drop down to 8 once it hit 10. In TTC I can get 16 PSI. My engine does have about 175k miles on it. Any thoughts?

Brad
 

·
Highway Demon
Joined
·
2,896 Posts
Sounds like a busted egcv. I had the arm from the actuator break off where it connects to the valve and had the same issues. I removed the egcv and brought it to a shop and had them weld the arm back on to the butterfly valve. problem fixed for me.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #4 ·
What would have caused the rod to snap? Old age? Or could the valve itself be stuck? Boost does go up to 16 PSI so I don't think its a stuck valve.
 

·
Highway Demon
Joined
·
2,896 Posts
No idea what would have caused it to snap, but I realized it's happened to a good amount of ppl besides me. It generally affects those that are in sequential or at least that's when it's most notable. TTC ppl depending on how you went TTC don't really have issues with it.

*While typing this I realize I spent most of the time in TTC and maybe the constant tension from locking the butterfly open caused the premature wear. Either way it is repairable and or replaceable. With so many ppl going single those EGCV should be pretty abundant or thrown away even.

Not entirely sure this is the answer to your problem but I hope it's as simple as this.
 
1 - 6 of 6 Posts
Top