Supra Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5,728 Posts
Discussion Starter · #1 ·
:sadance:

my car creaks like an old woman! It's coming from somewhere in the rear suspension. It's gotten so bad that it'll creak and groan for a while even after I get out of the car and walk away! I'm wondering if anyone else has had an issue like this? Thanks! :hay:

Notes:

215k miles on 1986.5 chassis;
original rear bushings;
ST sway bars;
Koni Sport shocks and Intrax springs
 

·
Registered
Joined
·
5,728 Posts
Discussion Starter · #8 ·
a_zepeda9236 said:
^^ i installed my tanabe sway bars upside down in the rear at first, and i set it back down and everytime i hit a bump it would smack it.. but i dont see how that would cause it to creak even after your done driving..
Well.... I installed it this way a YEAR and 12,000 miles ago! When I looked under there I saw that the sway bar had actually bashed in part of one of the subframe mounting donut casings and even took a little chunk off of the bottom of the upper control arm. Terrible!!!!
 

·
Registered
Joined
·
5,728 Posts
Discussion Starter · #11 ·
snake eyes said:
assuming that you installed it correctly, did you put some grease in there? when ive dont front bars on other cars if you didnt lube it would squeak like a bitch all the time

<l><l>
I greased those up with special order McMaster-Carr grease like there's no tomorrow. The creaking was coming from hardcore heavy-weight metal on metal contact.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top